Learn how you can get the iPhone 13 now!
sounbwoy's profile

Contributor

 • 

3 Messages

Tue, Sep 18, 2018 6:36 PM

Unable to send MMS Messages while on wireless

I don't remember having this issue when I had my Galaxy Note3, however, I now have a Nokia 6.1 (2018) and I have to disconnect from wireless if I want to send an MMS. Trying different apps, adjusting APN settings resetting..to no avail. It sounds like RCS will supposedly solve this issue, but until that magical day comes, does anyone have any other thoughts? Hard to believe the phone itself would be the issue, but then my wife and son don't appear to have that issue. We're on the same network, but their phones are way more $$ than mine.

ATTHelp

Community Support

 • 

171.4K Messages

3 y ago

Let's look into that for you, @sounbwoy!

 

First, you’ll want to verify whether your device is receiving adequate cellular reception as less than optimal signal strength could impact MMS sending and receiving time.

 

Second, try rebooting your phone by simultaneously pressing and holding the Volume Up and Power buttons. After the phone boots, release both buttons then try sending a test MMS message.

 

Finally, if the problem persists despite the first two steps, make sure your device’s storage isn’t approaching or exceeding its maximum capacity.

 

We hope this information helps!

 

Lar, AT&T Community Specialist

Contributor

 • 

3 Messages

3 y ago

Thanks for your response. I have already made those checks and followed those steps to no avail. As a reminder, the issue is that I am unable to send/receive MMS messages while the device is connected to Wi-Fi. I could have the strongest cell signal on the planet, but if I'm connected to Wi-Fi, sending/receiving MMS is not going to happen (stays stuck on "sending" when sending a message - using Android Messaging; I'll get a notification when I receive an MMS, but I have to turn Wi-Fi OFF to download/see the message) . I tried a different app (Textra) with no luck.

 

I did an extensive troubleshooting session with Nokia via email over several days. See their response in part, below:

>If you have less than optimal reception the delivery time of MMS may be increased or result in a higher chance of the MMS failing to send. Check the mobile coverage/reception indicator on your device. You should have a steady 1 to 2 (or more) bars of 2G, 3G or 4G coverage. Then turn your handset OFF for 30 seconds and then turn it back ON again to ensure your device is performing optimally;
 >Clear the cache from the Carrier Services (Settings>apps and notification>see all apps> carrier services> storage>clear cache;
 >Reset your network connection/perform a manual network selection (settings>network and internet>menu(3vertical dots)>reset WiFi, mobile data and bluetooth.  Then go back to settings>Network and Internet>Mobile Network>Preferred Network type);
 >Try sending another MMS to yourself;
Also there was this suggestion:
From Settings>>Networks & Internet >> WiFi >> WiFi Preferences >> Advanced, please make sure that Switch to Mobile Data Automatically is turned ON.
 Since MMS have to be sent with an active data connection and not WiFi, the device has to switch in order to send MMS, however in order for it to do so, this setting may have to be enabled.
 
Wile digging around in the device, I found this setting. Nokia did not have a real good answer:
While on Wi-Fi, the "Mobile Network State" shows as DISCONNECTED. When i'm NOT on Wi-Fi, the same setting shows as CONNECTED 
Is this correct? Should the phone not stay on Mobile Data even if I'm connected to Wi-Fi?
 
I also spoke with an AT&T Rep in Chat who unequivocally stated that MMS messages CANNOT be sent/received while connected to Wi-Fi...
 
So which is it? Some say it can be done; some say it can't.
The Nokia is brand new phone that I've only had a couple months. I like the device. I just don't think I have to jump thru hoops to get things to work on it.
 
Thanks
ATTHelp

Community Support

 • 

171.4K Messages

3 y ago

Hello @soundbwoy,


Thank you for clarifying your issue. We see that you have exhausted most of the troubleshooting options for your device. For that reason, we'd like to know a little more in regards to your situation. When you first obtained your device, were you dealing with this problem from the beginning? Are you able to view the specific settings for this issue? By that we're referring to the cellular option in Settings. From there, you should see a section titled For Limited Wi-Fi connectivity, which has a Drowpdown menu. After that, there should be the option for auto switch between Wi-Fi and cellular data. Please let us know if you are able to get this feature working. We look forward to hearing back from you!


Collin, AT&T Community Specialist

Contributor

 • 

3 Messages

3 y ago

Hello Collin. Thanks for your response. I was not able to find the setting to which you are referring. As a reminder, my device is a Nokia 6.1 (2018) running Android One. Model TA-1045. I don't use MMS everyday, so I honestly do not remember when the issue first occurred. It may have been a couple weeks after getting the device when I tried to send an MMS and had the issue. I know it

all started when I changed the setting from SMS to MMS. I didn't want to receive individual replies

Screenshot_20180924-183503.jpg

 

Thank You.

Dean Irwin

Contributor

 • 

1 Message

2 y ago

Hello, wanted to reply to this message, thanks for so much for details, they help a lot.

Based on my own experience I believe this is based on the phone it self.

My personal experience:

My wife and I using Motorola G4 plus (unlocked phones) with AT&T prepaid service, her Android version is 7.0 while mine is 8.0.

So when she sends and receives any pictures via regular text message, she has to turn her mobile data On, while on my phone which is the same model, I do not turn on any mobile data or wi fi and sending and receiving pictures works fine.

Recently I purchased also unlocked Nokia 7.2 phone, have the same APN settings as on my Motorola, however any MMS messages can be send only when Mobile / Cellular data turned on.

Called AT&T, was told that wi fi should be Ok to send MMS, and was recommended to call phone manufacture. Based on my own experience and reading the information on forums, there is no confirmed specific answer to this.

Need help?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.