Uniquely for you. Preorder the new Google Pixel 6.
soxuga's profile
soxuga
#1 Star!
Helpful 1
10th stratosphere!

Teacher

 • 

20 Messages

Sat, Mar 18, 2017 5:30 PM

Unable to receive MMS messages from some people

I'm unable to receive MMS messages from some people. I'm using an unlocked Moto Z Play and the stock/standard Google Messages App on Android 6 Marshmallow and just upgraded to Android 7 Nougat. Still having the problem. It tells me I have received a message, but it says "unable to download, touch to try again." I can retry over and over and nothing will download. Tried wiping the cache partition and tried a factory reset. Using APN settings provided by an AT&T rep. My hunch is that because the Moto Z Play doesn't natively support AT&T's "advanced messaging," the problem is from users who have a phone with advanced messaging turned on, and there is some "advanced messaging" code tacked onto the MMS that Android doesn't know what to do with, so it's preventing the message from being displayed because it thinks the message hasn't completely downloaded. Can someone at AT&T Tech Support test this? I've been an AT&T subscriber for a decade, but I love the Moto Z Play and it's INSANE battery life, and Verizon offers the phone on their network. I don't want to switch to Verizon and accept the bloatware (hence the purchase of an unlocked phone with stock Android), but I may have to if I can't get MMS to work correctly. I use the phone for work, and "hey sorry I didn't receive your message" isn't​ acceptable when I have to use MMS to communicate with colleagues. Please help! Has anyone else experienced this?
jii

Professor

 • 

1.5K Messages

5 y ago

Wiping cache and hard resetting wouldn't do anything here...

 

Are incoming MMS messages failing from the same set of specific people, or is it failing randomly?

 

Do this...turn off WiFi, confirm that mobile data is on, and send yourself a test MMS. 

David4749

Employee

 • 

120 Messages

5 y ago

I would try what Jii has stated. It does sound like these are coming through as a group message,MMS.  So data must be turned on for these to come through! 

soxuga

Teacher

 • 

20 Messages

5 y ago

I'm only experiencing the error for certain people. I can send MMS and I can receive MMS, but for certain people, the MMS messages won't download. I've turned off wifi and texted myself a picture and it worked just fine.
soxuga

Teacher

 • 

20 Messages

5 y ago

Data is definitely turned on and working. I can browse the web and send/receive MMS messages without WiFi on. But for the people whose MMS messages I can't receive, it's a constant problem. Nothing I've tried seems to correct the issue.
jii

Professor

 • 

1.5K Messages

5 y ago

Are these specific people using Verizon or Sprint? 

soxuga

Teacher

 • 

20 Messages

5 y ago

I know one is using a Samsung Galaxy 6 on AT&T
jii

Professor

 • 

1.5K Messages

5 y ago

I haven't really come across any problems with using advanced messaging except for when it was first implemented. Then again, I've been using Hangouts and Voice for all of my messaging for a little while now. 

 

Unless someone else has something of substance, I'd say have those people make sure that advanced messaging is unchecked, and test from there. 

soxuga

Teacher

 • 

20 Messages

5 y ago

Is asking someone else to change a setting on their phone is the right answer? Since the "advanced messaging" is carrier-specific/proprietary, I would think AT&T could use a Samsung phone with "advanced messaging" to troubleshoot whether this setting makes a difference in whether or not the Moto Z Play can receive the MMS, and if so, i would think it's an issue with AT&T's proprietary "advanced messaging," right?
jii

Professor

 • 

1.5K Messages

5 y ago

That's exactly what I'm getting at. We're trying to troubleshoot here, after all, and I don't know if you have much experience troubleshooting with actual AT&T employees, but it can be...cumbersome...at times. On the other hand, having a friend change a setting only to change it back immediately after sending a quick text would be rather quick AND convenient for the most part, not to mention quite helpful on the troubleshooting side. Then again, what do I know? I'm just a user like yourself.  

soxuga

Teacher

 • 

20 Messages

5 y ago

Ha "cumbersome" is a good way to describe it
GLIMMERMAN76

ACE - Expert

 • 

22.4K Messages

5 y ago


@soxuga wrote:
I'm unable to receive MMS messages from some people. I'm using an unlocked Moto Z Play and the stock/standard Google Messages App on Android 6 Marshmallow and just upgraded to Android 7 Nougat. Still having the problem. It tells me I have received a message, but it says "unable to download, touch to try again." I can retry over and over and nothing will download. Tried wiping the cache partition and tried a factory reset. Using APN settings provided by an AT&T rep. My hunch is that because the Moto Z Play doesn't natively support AT&T's "advanced messaging," the problem is from users who have a phone with advanced messaging turned on, and there is some "advanced messaging" code tacked onto the MMS that Android doesn't know what to do with, so it's preventing the message from being displayed because it thinks the message hasn't completely downloaded. Can someone at AT&T Tech Support test this? I've been an AT&T subscriber for a decade, but I love the Moto Z Play and it's INSANE battery life, and Verizon offers the phone on their network. I don't want to switch to Verizon and accept the bloatware (hence the purchase of an unlocked phone with stock Android), but I may have to if I can't get MMS to work correctly. I use the phone for work, and "hey sorry I didn't receive your message" isn't​ acceptable when I have to use MMS to communicate with colleagues. Please help! Has anyone else experienced this?

 

@soxuga @jii

 

i doubt that advance messaging is a problem or I would not get mms texts from my kids.  They are using branded s6 devices.  I am using a google pixel xl and a honor 8x I have works to.

David606

Employee

 • 

3.5K Messages

5 y ago

Advanced Messaging has no effect on non-branded phones. If your Moto phone is provisioned properly and the IMEI number is correct in the system, Advanced Messaging cannot be provisioned because it has to be a branded AT&T device.

 

So it's normal MMS as the only method available. MMS isn't really something that works sometimes and then doesn't other times. It's kind of all of nothing. If you can send an MMS and mobile data is working then the capability to do so exists.

soxuga

Teacher

 • 

20 Messages

5 y ago

Yeah, but i believe Pixel is "advanced messaging" capable. Here is another example I found of someone experiencing the same issue. It seems to have something to do with the messaging standards. Does the Honor 8 have a setting to turn on "advanced messaging" or text read receipts? https://forum.xda-developers.com/pixel-xl/help/pixel-xl-message-mms-issues-t3488061/page2
soxuga

Teacher

 • 

20 Messages

5 y ago

I think that's the root cause here - the Moto Z Play doesn't offer those "advanced messaging" capabilities (like read receipts for texts), and it seems the issue may be with phones sending all the extra info that allows advanced messaging to work. For whatever reason my phone doesn't think the message has been received, so it doesn't display. I don't know if it's (a) the extra info being sent from phones with "advanced messaging"enabled, (b) an issue with how the network/communication protocol deals with those messages, or (c) how the Android Messages app interprets those messages.
soxuga

Teacher

 • 

20 Messages

5 y ago

UPDATE: Google just pushed an update to "Carrier Services," and after the update I was able to receive a picture MMS (sole recipient, not group MMS) from someone who I was unable to receive MMS from before. So it looks like the Carrier Services update may have solved this problem. Here is the description of Carrier Services from Google Play: "Carrier Services helps carriers provide mobile services using the latest networking capabilities. Carrier Services includes support for enhanced features in the Android Messages app.". Again, I'm on an unlocked Moto Z Play, purchased from a non-AT&T retail store (Best Buy). Phone came with Android 6 Marshmallow, upgraded to Android 7.0 security build 1/1/2017. I was experiencing the issue on both Android 6 and 7.
Need help?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.