Skip to main content
AT&T Community Forums
D
Davenlr

New Member

 • 

23 Messages

Mon, Aug 10, 2020 7:00 PM

SIM status

On my About Phone screen is says Phone Number Unknown

On my Sim status it says AT&T then Network AT&T, then Phone Number on SIM Unknown

 

It appears to be working correctly, just curious why it doesnt know my phone number

 

Responses

Brand User
ATTHelp

Community Support

 • 

133.9K Messages

2 months ago

Welcome back, @Davenlr!

Are you still using the prepaid SIM you activated in Little Rock with the unlocked Motorola Edge, or did you pick up another SIM?

Power your device off, pop out the SIM, then reinstall it. Power your device back up then check back in your Settings for any changes. Let us know what you find. Thank you!

Keny, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Davenlr

New Member

 • 

23 Messages

2 months ago

Yes, still using the same phone and SIM.

Turned off the phone, removed SIM, reinserted SIM, started phone.

Said ATT at the top.  Still does not show phone number.

Like I said, its working fine, just seemed odd, and not sure it wont affect some app down the line.

BTW, At my house, Sprint is 6 Mbps, T-mobile 5G is 2 Mbps (really), and ATT 5Ge is 168 Mbps.  We are supposed to have real 5G here, but phone hasnt connected to it yet anywhere in town (which is fine, speed is good) so not sure if the two are related.

(edited)

Get started...

Ask a new question