Skip to main content
AT&T Community Forums

Contributor

 • 

1 Message

Fri, Mar 8, 2019 5:29 PM

Regular text messages wont send when data is off and no wifi

After this latest update, I can receive text messages but I cant sent them unless I have my data turned on or under WIFI.  These are regular text messages that I am trying to send.  Every time I try, I get a pop up message that  says "Turn on mobile data?".  Can someone help me with this?  Also, I keep my data turned off, unless needed, I share with others and dont like to run it down.  I know their is a way since I have done it this way forever.  This new update has done something to my phone.  I have a Samsung galaxy 7

Responses

Accepted Solution

Official Solution

Tutor

 • 

2 Messages

2 years ago

Turn off the Advanced Messaging in the Messages settings.  It fixed mine right away.

Brand User
ATTHelp

Community Support

 • 

140.5K Messages

2 years ago

Good afternoon @krs1931,

 

Allow us to lend a helping hand. Try restarting your device. If that does not help please try walking through some troubleshooting steps in our Troubleshoot and Resolve tool. Just select your device and the issue that you're experiencing. Thank you.

 

Makaela, AT&T Community Specialist.

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Tutor

 • 

2 Messages

2 years ago

I had the same problem.  Turning off Advanced Messaging in the Messages settings fixed it for me.  

Contributor

 • 

1 Message

2 years ago

What a stupid update. So does that mean I don't need unlimited texting on my plan. How will you the service differentiate regular text vs multiple group text charges on data usage?

Get started...

Ask a new question