The Samsung Galaxy Z Flip4
kapadiav10's profile

Contributor

 • 

3 Messages

Tuesday, November 10th, 2015 9:30 PM

Note 5 won't update to N920AUCU2AO16

I installed samsung pay, and it's asking me to do an update. I read online that the N920AUCU2AO16 update is available for the note 5, but i'm stuck on N920AUCU1AOGG, with a message that shows "Current software is up to date" (can't check again). Does the phone need an active AT&T sim card in it? that's the only thing i can think. I'm using a canadian sim right now, but I am in america, on the AT&T network, using wi-fi. 

 

Any help is appreciated- really want to make the most use out of this phone! Smiley Very Happy

ACE - Sage

 • 

104K Messages

7 years ago

You either need an ATT SIM card or visit a Best Buy and have them flash the update for you 

 

GLIMMERMAN76

ACE - Expert

 • 

23.5K Messages

7 years ago

Samsung pay won't work if it detects a foreign carrier sim. Also it only works with us based banks.

Contributor

 • 

3 Messages

7 years ago

thanks a lot for the reply! Tried with an at&t sim as well, i will try the best buy solution. 

Contributor

 • 

3 Messages

7 years ago


@GLIMMERMAN76 wrote:
Samsung pay won't work if it detects a foreign carrier sim. Also it only works with us based banks.

Thanks a lot for the insight. I might have to wait until samsung pay starts working with canadian banks- guessing i may need to get a canadian carrier based phone as well at that point Smiley Tongue. Again, thanks for the reply. 

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.