Skip to main content
AT&T Community Forums

Tutor

 • 

6 Messages

Sun, Feb 25, 2018 6:57 PM

Not receiving messages

Hello

 

I have a Google Pixel 2 XL fully updares. I'm being informed by multiple friends that I haven't received their MMS message, missing multiple messages on group chats and now just not receiving texts from 1 on 1 conversations. I thought it was the texting app but I downloaded a new one and same problem. What can I do?

Responses

Tutor

 • 

2 Messages

3 years ago

I am having this issue as well.  I realized it was happening a few days ago, but not sure how long it has been going on.  I get maybe 5-10% of MMS messages, and that's it.  Seems completely random.  I put my SIM card in an old iPhone and I get all test MMS messages that are pictures or group text replies.  Everyone gets my messages.  I did a factory reset on my Pixel 2 XL with no restore, issue still happens.  Does anyone have any updates on this whether it is a google/android or AT&T issue?  I will probably try to give AT&T a call today.  Already have a case open with Google but haven't gotten anything useful from them yet.

esker2c

Teacher

 • 

13 Messages

3 years ago

Similar to @tkr843243, I went back to my Nexus 5X this week. I have not been losing any messages now, I verified this at the end of the day with my groups. Plus my group texts make sense now. Smiley Happy  So it is definitely something between pixel2 and ATT. Hope a solution is published soon. I miss my pixel2, its better than the 5X.

Tutor

 • 

2 Messages

3 years ago

Another update.  I just turned off Enhanced LTE on my Pixel 2 XL and so far I'm getting all messages.  I will also update my case with Google to let them know.  I'm not going to say this fixed it quite yet though until more time passes.  I will keep testing with friends and see.  So far I am getting 100% of texts for MMS (pictures and group replies)

Tutor

 • 

6 Messages

3 years ago

Just a quick update. Google is aware of this issue and have dedicated several of their engineers in resolving this issue. They even reached out to me to use my phone as a test case. I will definitely let them know about the enhanced LTE situation.

Tutor

 • 

5 Messages

3 years ago

Excellent, thanks for your help. I ended up replacing my sim card and turning off the enhanced LTE option. For now I've been getting more messages. Hopefully Google is able to solve the issue!

Tutor

 • 

4 Messages

3 years ago

@yoolyalana - any update? I want to keep this thread fresh until there is a solution. My frustrations and missing messages has continued.

Tutor

 • 

8 Messages

3 years ago

I am still encountering the issues mentioned here. It's really, incredibly annoying!

 

As a stopgap, I've started using Textra with the settings set to "Legacy" in lieu of the Messages app. But it's really annoying that I cannot use the app my phone comes with for a very basic function with complete certainty.

 

Still waiting for AT&T and Google to figure this one out! But I don't know what else to do.

Tutor

 • 

6 Messages

3 years ago

I tried Textra but still wasn't getting messages. What does the legacy
setting provide that the regular settings do not? I'm pathetic happy with
ant work around at this point as I am annoying all my friends, family and
coworkers bit constantly asking to be updated on missing texts.

Tutor

 • 

8 Messages

3 years ago

@CHumphries, I'm not really sure. It was something I did based on a post in this thread in the Google Pixel Forum: https://productforums.google.com/forum/?utm_medium=email&utm_source=footer#!msg/phone-by-google/BwyxuNcJj-U/bXRWPpiDBgAJ

 

Someone there had suggested it as an alternative, though I'm not even sure it's working, because it's nearly IMPOSSIBLE TO TELL.

 

But anyway, if you want to try it, go to "Settings", then "MMS", and then switch the "MMS Behavior" from "System" to "Legacy".

Contributor

 • 

1 Message

3 years ago

I"m experiencing the same issue.  Turning off enhanced has helped some, but is not a complete fix.  Good to know I'm not alone.  Hugely frustrating because the phone is otherwise great.  But this going on for a month is almost unforgivable.  

esker2c

Teacher

 • 

13 Messages

3 years ago

Enhanced LTE is off for me and I'm still losing messages. I had used my 5x for a week and everything was fine. Tried pixel2 again in hopes that it would work. Back to the 5x we go.

Tutor

 • 

6 Messages

3 years ago

 

@smurfsriot Currently they are tracking my phone as well as several other phones in hopes to find a solution and resolve this issue. They are aware of turning off the LTE enhancement but have noted that this does not solve the issues. Please note that Google is taking this issue seriously and are diligently working to resolve this issues. I am getting multiple e-mails work log (which honestly I do not understand as I am not tech savvy. LoL) But note that they are working on it and also aware of this forum and are tracking the messages. So please keep the updates/complaints coming. Thank you. ~just an employee of Google who is wanting to help

Tutor

 • 

4 Messages

3 years ago

So where is AT&T support on this one? I've been having the same issue on the Pixel XL 2 which started recently. I get "message failed to download" issues for about 90% of group messages. All of my friends, family and colleagues communicate almost exclusively through group messages, so it's been really frustrating. I'v been to the store 3 times, checked APN settings, replaced my sim, and factory reset. Any help?

Tutor

 • 

5 Messages

3 years ago

Ive focused primarily on going to AT&T. I did all the steps you did minus the factory reset. After turning off Ehanced LTE ive managed to get every message, picture, group message since then. Anyone else experience this too?

Tutor

 • 

6 Messages

3 years ago

Turning off wnhanced LTE did little to help me. Best response I have had is
using Textra in Legacy mode. Still missing a text here or there but not to
the degree I was previously. The benefit here is also that Textra notifies
you when it can't download. Still though, where is some acknowledgement
from AT&T and Google about this issue. No outreach to customers, no "we're
working on it." Just complete silence. Unacceptable.

Get started...

Ask a new question