Skip to main content
AT&T Community Forums

Tutor

 • 

6 Messages

Sun, Feb 25, 2018 6:57 PM

Not receiving messages

Hello

 

I have a Google Pixel 2 XL fully updares. I'm being informed by multiple friends that I haven't received their MMS message, missing multiple messages on group chats and now just not receiving texts from 1 on 1 conversations. I thought it was the texting app but I downloaded a new one and same problem. What can I do?

Responses

Contributor

 • 

1 Message

3 years ago

Having the same issue with Pixel 2 XL.  Tried a full factory reset without a restore and still not able to receive MMS and group messages.  Started this last week and has been getting worse.

Tutor

 • 

8 Messages

3 years ago

This is happening to me too! I have a Pixel 2, and can first confirm the missing messages in group texts on February 22, 2018. There is no rhyme or reason to whose texts I receive and whose I don't. I will try turning off the Enhanced 4G LTE network thing. It's just so frustrating, because I don't know when I'm missing messages unless someone somehow tells me!

 

I've also been getting weird downloading texts (that won't download) in one-on-one text conversations. When I ask if the sender actually sent me anything, they didn't! This has happened with multiple people as well.

 

My Pixel 2 was working fine for several months! I'm not happy with AT&T about this.

Tutor

 • 

3 Messages

3 years ago

Any any fix for this yet? 

Quite annoying

esker2c

Teacher

 • 

13 Messages

3 years ago

Tutor

 • 

3 Messages

3 years ago

That post is from last year...

Tutor

 • 

6 Messages

3 years ago

Pixel 2 XL - same issue.  Either not receiving messages at all, or they say they need to download....but it fails every time.

 

Tried manually entering the APN per AT&T specs; tried swapping in/out Verizon SIM from work phone; restarts/resets; etc....  Nothing.

 

Isolated to MMS from iPhone users - for me - though I understand others aren't getting from other Android users.

 

Seems to have started a few weeks ago and is getting progressively worse.

Tutor

 • 

4 Messages

3 years ago

Add me to the list - Pixel 2 XL with AT&T business account. Random missed text messages. I only have experience with these being missed from iphone users (although it could be Android but cannot confirm). Also it appears (not definitive) to be really long SMS/MMS messages. Also appears to have been within the last two weeks or so. I have updated APN (although no settings were changed), new SIM, turned off enhanced LTE. Both AT&T and Google seem to not know what is going on and neither seem to admit that there is a problem, or they seem to blame the other. Clearly, however, there is an issue. I encourage everyone reading this to reply with a message. Hopefully this will provide visibility to the AT&T team and they can research. Otherwise, I have to change carriers as this is unacceptable for a business account.

esker2c

Teacher

 • 

13 Messages

3 years ago

@smurfsriot So turning off LTE did not help?

@Apatel: Sorry you're right, that verizon post was last year. Someone who knows I've been losing messages forwarded to me and I saw January and thought it was relevant. My bad.

 

I'm trying my 5X to see if the Pixel has something to do with it. I didn't see any posts in this thread that reported the problem with non-Pixel, so I want to rule out. If I can confirm the problem on the 5X, I guess I'll have to try another carrier. Losing random messages is not acceptable, I have to find a solution to this.

Tutor

 • 

4 Messages

3 years ago

@esker2c - To be clear, I turned off the option for "Enhanced 4G LTE Mode" and I can't tell to be honest. I have seen many people mention that it does work but I just don't have enough data/time to say if it does or does not. I have it off for a couple days now and I believe that I am getting text messages but really the only way to know for sure is if I constantly ask my contacts if they have sent anything new to me, lol. I have been asking two close contacts who have iphones and I was missing several of their texts about a week ago. So far so go but again, this is pure anecdotal.

 

I also reached out to Google today and they are sending me a new Pixel 2 XL. Which is a nice gesture but I don't think this will help. I feel this is a software issue or communication specifically with AT&T and Pixel 2 phones. Neither companies seem to know what is going on but both seem to acknowledge there is an issue. 

 

I am just going to take my new SIM card and new phone and hope for the best. If the issue persists in a week, I have no choice but to change carriers or get a new phone since I have a business account and cannot be missing client/customer texts (who knows how much this has cost me already!!!)

Tutor

 • 

7 Messages

3 years ago

This exact same issue is still happening to me. I definitely dont think its a phone issue, my brother and I are in a group text and he has the same phone I do, Pixel 2, and he gets texts, but I won't. An iPhone user is also on the group chat and I dont get their responses either. It seems to have only started recently and getting worse.

 

I did a factory reset yesterday and it still persists. That was a pain in the butt for nothing. Anyways, anyone have a solid fix for this or know when Google plans to push out a software update?

esker2c

Teacher

 • 

13 Messages

3 years ago

@jmrozek  Are you and your brother both using ATT?

Tutor

 • 

7 Messages

3 years ago

yes, both on ATT both on Pixel 2 smartphones. Group chat varies. Just tested with 2 iPhone users and got one response, but not the other. 

 

Update: Just got off the phone with google. They said check with someone else on ATT and see if its the same APN, if not add the one that is working. Secondly, check with ATT and see if there is some issue on their end. If all else fails contact them again.

 

I also tested this issue with 2 iPhones and I get one of their responses but not both. 

Tutor

 • 

5 Messages

3 years ago

Just had a MMS go to "Message Not Downloaded." First time that I've known
about since turning off Enhanced LTE, so it seems that's not a full
solution.

Tutor

 • 

8 Messages

3 years ago

I've gotten a bunch of messages that were "unable to download". It's so weird. I've gotten at least one such message since I turned off the "Enhanced 4G LTE Mode".

 

I literally don't know how I can confirm whether I'm getting all messages or not! It's unreasonable to have to follow up with people on an individual basis to know if you received all the messages from everyone in a group chat. It's pretty much like I will never have full confidence again that I am receiving all messages that are sent to me.

Tutor

 • 

6 Messages

3 years ago

Same situation. Turning off Enhanced worked for a few days but seems the
problem persists w Android and Iphone. Definitely haven't received all MMS,
group chat and/or pictures. Haven't documented any missing SMS yet.

Get started...

Ask a new question