Skip to main content
AT&T Community Forums
Announcements
Get to the head of the class with our Back to School deals!

Contributor

 • 

2 Messages

Wed, May 24, 2017 1:13 AM

My Samsung Galaxy S8 won't send text photos

Please help, my Samsung Galaxy S8 will not send texted photos. It says it's sending forever and then it says message failed to send. I have a microcell so I have a good strong signal. I also have great wifi. I'm not sure why this is happening with a brand new phone. This also happened with my S6. I tried all the troubleshooting I could find online and no help. I restarted, I'm updated, I have space, still nothing. 

Responses

Brand User
ATTHelp

Community Support

 • 

124.8K Messages

3 years ago

Good Afternoon @squinn77!

 

Welcome to our Community Forums! This is definitely a great phone to have. I regret to hear you are experiencing these picture messaging issues. Let’s go over a few solutions together.

 

A key component of sending any multimedia message is excellent cellular data connection. The MicroCell should establish a great connection for your phone to send picture messages, however while solely on Wi-Fi the picture message will not be able to send out while off of cellular data. You can only send picture messages on Wi-Fi when you have Wi-Fi calling enabled. To learn how to enable this feature on your phone, check out our support article here.  In other words, you should only send multimedia messages on the MicroCell or Wi-Fi  Calling.

 

If you are still running into this problem with your device, I invite you to run your phone through our Troubleshoot & Resolve Tool. Select your make and model phone, click on Messages to get started.

 

I hope this helps! Let us know if you have any additional questions.

 

Shenoah, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Contributor

 • 

1 Message

3 years ago

I am having the same issue. I have a really good wifi connection, and microcell and it takes forever to send one picture. 9 times out of 10 I get the error msg that I am unable to send the message. I just keep retrying. I have wifi calling enabled, and still no luck. I am seriously considering switching carriers. I just bought this S8 and it is too expensive to not use fully.

Tutor

 • 

1 Message

3 years ago

This has ZERO to do with signal strength, I also have experienced both on as well as OFF WI-FI. Google the issue Samsung, there are thousands with same issue ("signal strength", seriously??)

 

Please eliminate the must-be-something-else answer, and fix your phone. Or maybe we should all roll over to the iPhoneX. Hmmm...¯\_(ツ)_/¯

 

Contributor

 • 

1 Message

3 years ago

I turned Wi-Fi calling reboot the phone still not sending pictures. This is a brand new phone I also have a micro cell. How can we fix this?

Contributor

 • 

1 Message

3 years ago

Since your carrier can't seem to answer your question, I'll give it a shot. I have Verizon, been running into the same issue for a few weeks. I use the message+ app for texts, and have had to restart my phone to get pictures to send(every time I send one).

Finally got frustrated, and opened the message app, gave it permissions, and opened a message. The picture had sent, and they are still sending. Not sure why there are two texting apps, but just open the regular message app or message + and give it permissions. Seems to be working for me.

JD

 

Guru

 • 

382 Messages

3 years ago

Do you have a newer SIM?  An old SIM and outdated apn settings could cause issues.

Contributor

 • 

1 Message

3 years ago

Pls excuse my lack of knowledge, but when I open message+ app, I searched and found no where to give it permissions

Contributor

 • 

1 Message

2 years ago

SOLVED... Well for now it seems. Apparently the factory Samsung/Android app is garbage. I also have two GS8 phones and At&t microcell. After reading several forums finally downloaded Textra messaging app and can now send MMS while wifi is enabled. Seems to be an issue with multiple carriers. I hope this helps some of you and hopefully they will get a real fix eventually.

GLIMMERMAN76

ACE - Expert

 • 

19.8K Messages

2 years ago


@Mdtaylor wrote:

SOLVED... Well for now it seems. Apparently the factory Samsung/Android app is garbage. I also have two GS8 phones and At&t microcell. After reading several forums finally downloaded Textra messaging app and can now send MMS while wifi is enabled. Seems to be an issue with multiple carriers. I hope this helps some of you and hopefully they will get a real fix eventually.


the problem is the microcell....

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Contributor

 • 

1 Message

2 years ago

I always sent pictures with text messages. I don't know what happened because I can't send them now and I don't know what changed. It was a sudden change and I'm wondering if the update I did had anything to do with it. Sure would like it fixed. My business involves sending photos and now I can no longer do that. Very disappointing !

Contributor

 • 

1 Message

2 years ago

Same with my Samsung S8. Could text photo until 3 days ago. I have the MicroCell and I have a strong internet signal.

Cannot figure out what is wrong. Going to my carrier, AT&T, tomorrow to see they can help with the problem.

Contributor

 • 

1 Message

a year ago

I have this problem as well. I have called in then it works for a while and then right back to the same crap..  Very frustrating and I have great internet connection as well as the microcell.  You would think as much as the service cost each month that they would make sure it is useable

GLIMMERMAN76

ACE - Expert

 • 

19.8K Messages

a year ago


@Lacylou wrote:

I have this problem as well. I have called in then it works for a while and then right back to the same crap..  Very frustrating and I have great internet connection as well as the microcell.  You would think as much as the service cost each month that they would make sure it is useable


If you have a s8 why not use wifi calling and you would not have problems.

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

New Member

 • 

2 Messages

a month ago

Not with ATT anymore, but Delete your thousands of text messages (especially with pictures), even though you don't want to. I have an S8 and have been having the same problem lately. I sat on the phone with my carrier today for over an hour, trying everything to fix the same problem...pictures won't go through, but the text does. I even asked her if it could be that I have too many text messages, and my phone is too full. She said "No, no...wouldn't be that". So she said they'd send me a new SIM card. She also told me to call Samsung to see if they've been having any of the same problem, so I did...he said he couldn't do anymore than Spectrum already did. So I deleted over 4,500 text messages, and now my pictures go through just fine!!! I've done that several times when my phone begins to give me trouble. It solves lots of problems. I'm sure I have too many photos on my phone too...darn cute grandkids!

New Member

 • 

2 Messages

Well, I'm replying to my own comment...Even though my pictures began going through last night after deleting a lot of texts, it seems I have the same problem this morning. So, now I'm not sure. Even my daughter says deleting her thousands of texts helps her phone behave much better, and it's worked for me several times before, for other problems.

Get started...

Ask a new question