Announcements
Don’t miss your chance to add AT&T Protect Advantage. Peace of mind, starting at $15 per month. Open enrollment ends 3/31. See all protection plans.

Teacher

 • 

26 Messages

Wed, Nov 6, 2019 6:42 PM

MMS does not work when Wifi Calling Activated

Samsung Galaxy S10 

I was having a ton of trouble receiving picture messages (MMS) whenever Wifi Calling is active.

I tried Stock Samsung Messages app, Textra, and Google Messages. (currently still using Google Messages)

 

My home has horrible reception (outside great, inside horrid), so after Wifi calling went active (we used to use a microcell that had horrible data speeds) we figured most issues would be fixed.

Well now, I get day late clues (no notification at all) that someone sent me a MMS and i have to "download" it. Or, if someone sent me a MMS while wifi/wifi calling were turned on, I would see the spinning photo box, but it would never show a picture. Not until I restarted my phone in good data coverage or by random it would work. I thought it had something to do with Iphones sending to my android (as most of the people I know use iphone), but found out last week that it was Android as well. After hours of trial and error, I thought it was wifi itself. But this happens at work (where I have great 4glte and 5g) and while at home (where I have horrible 4glte inside the house). After digging further and further, I found WIFI CALLING to be the culprit. 

 

If i receive a MMS while wifi calling is active, It will not download. You cannot receive the message and just turn wifi calling off, as it won't download still. You have to receive the message while wifi calling is turned off to properly receive the picture message.

Anyone have any idea on what to do? 

Responses

Tutor

 • 

11 Messages

2 months ago

Note 10 with wifi calling on won't recieve pics just circle of death.. but as soon as she turns it off it opens. I have heard of no real fixes or updates. 

Contributor

 • 

1 Message

2 months ago

Same issue here with the S9+.  Very frustrating!

Contributor

 • 

3 Messages

2 months ago

Seems that AT&T does not care if it ever gets fixed. I spent some time with
them explaining the issue in detail two months ago. It can't be the Wi-Fi
or my Internet connection since my reinstalled Micro-Cell works fine. Here's
a rub, AT&T just notified me my plan is no longer available and they are
increasing my monthly payment by $5 and giving me 3 GB more data that I
don't need or want. My wife and I combined never come close to 1 GB and now
we have 9 GB for what??

New Member

 • 

6 Messages

It's interesting to me that AT&T could potentially be motivated to not fix this issue. (More mobile data used the more potential $$$) Is there anyone out there that is having this problem on the Unlimited Plan? (That could also squash that theory but so far no one I've talked with this problem has an unlimited plan. Could be just a coincidence...)

Tutor

 • 

5 Messages

2 months ago

I have a Samsung S10 and was also having problems receiving MMS messages when WiFi Calling is ON.  Turning off WiFi Calling solved the problem.  Then I tried this solution - going into Developer Options and enabling Mobile Data Always Active.  This seems to have solved 2 problems.  I can now receive MMS messages with WiFi Calling set to ON.  In addition, I was not getting texts notifications at all when my screen was lit.  I only received text notification when my screen was locked.  Now I am receiving text notifications when my screen is lit again just as I did with my previous Samsung S7.

behenchod

New Member

 • 

18 Messages

Enabling data with wifi on prevents wifi calling from enabling. So it's the same as turning off wifi calling.

Teacher

 • 

26 Messages

2 months ago

Turning Mobile Data Active Always has worked for me also. The point is, we shouldn't have to. 

behenchod

New Member

 • 

18 Messages

Turning on mobile data always on prevents wifi calling from enabling. So good "solution"

New Member

 • 

6 Messages

Shhh the grown ups are talking...

Contributor

 • 

3 Messages

2 months ago

That works if you have an AT&T signal that your phone can use. The issue
occurs when there is no signal available from an AT&T tower and only a Wi-Fi
signal is available. Then texts will arrive "sometimes" and MMS will not
download while on the Wi-Fi calling setting. Calls function as they should
however a couple of months ago I did not receive Voice Mail Messages while
using Wi-Fi calling. I believe AT&T has corrected that issue but not MMS.

Tutor

 • 

5 Messages

2 months ago

I agree.  We shouldn't even have to have this conversation.  AT&T should have fixed this problem a long time ago.

Tutor

 • 

2 Messages

2 months ago

I have spoken to tech support and they tell me they are aware of an issue and a fix "should" be arriving by tomorrow afternoon 

Teacher

 • 

26 Messages

2 months ago

This has been going on for almost a year. I finally figured it out through this forum. I highly doubt "tomorrow" they'll have it snuffed away. As stated previously, they were aware of it back when I first called them and said it was a samsung issue, not ATT. 

New Member

 • 

6 Messages

I dealt with the same and was even directed to speak to Samsung.... So frustrated! Any insight on how you fixed it?

Tutor

 • 

5 Messages

2 months ago

Here's a post from a Samsung message board.  Clearly they are pointing fingers at each other.

 

Dec 9, 2019 10:32 AM

Re: MMS does not work when Wifi Calling Activated

This has been going on for almost a year. I finally figured it out through this forum. I highly doubt "tomorrow" they'll have it snuffed away. As stated previously, they were aware of it back when I first called them and said it was a samsung issue, not ATT. 

Tutor

 • 

2 Messages

2 months ago

I haven't had trouble until the last week or so. Worked fine up until then for the last year or so since I started using wifi calling. Just came across this forum today. Sorry, had wishful thinking haha 

New Member

 • 

1 Message

2 months ago

We bought two S10s at Thanksgiving and had the problem immediately. I agree it seems to work when wifi is off. Isn't that just ATT's way of getting us to use more data?

New Member

 • 

2 Messages

1 month ago

I've been facing this issue for months as well. The only thing that works is to turn off WiFi and wander away from my house where I can find cell coverage. Ridiculous that this is still ongoing. iPhones don't seem to have this issue, just Samsung devices and since ATT only allows Samsung android devices to use WiFi calling (when I was looking for a new phone over a year ago) I'm stuck.

New Member

 • 

3 Messages

1 month ago

same issue here. hey at&t and samsung do you all think you could put your heads together and figure this out.

this getting to the point to where im considering changing service provider. HAD ENOUGH (Edited per community guidelines)>

(edited)

New Member

 • 

2 Messages

4 weeks ago

This is unacceptable.. My wife and I have this same issue. We both have a Samsung Galaxy S10. We have been loyal to AT&T for over 15 years, but this issue is testing my loyalty. I have enabled "Developer mode" and turned on "Developer options > Mobile data always active", but that does not fix this issue. I attempted a restart as well. The software and default messages app are both up to date on each phone. The only way to receive images via text message is to turn off Wi-Fi.

It is even more frustrating for group messaging. We will get a text with an image from a person in the group but it will come directly from the person, not in the group conversation. Then we need to turn off Wi-Fi, click the image to "Resume" downloading, then when the image downloads, you get a flood of repeat text messages that came after the image download.

Just as others described, I can send images via text message without any issues. I simply cannot receive images via text message unless I turn off Wi-Fi. I tried turning off just Wi-Fi calling, but you really need to completely turn off Wi-Fi. When will this be fixed!?

New Member

 • 

2 Messages

Same issue on galaxy s10 plus and galaxy s8

New Member

 • 

3 Messages

@jspadea it is (Edited per community guidelines) i paid over a thousand dollars its very frustrating

(edited)

lizdance40

ACE - Sage

 • 

70.2K Messages

Frankly baffled. I have used AT&T wifi calling with a Samsung Galaxy S7, S8, S9 and never had a problem sending multimedia over Wi-Fi calling. More recently I have been using a pixel 3 XL, also never had a problem sending or receiving multimedia messages over Wi-Fi calling

🐾 (The following is included after all posts to save typing) I don’t work for AT&T. My replies are based on experience and reading content available on the website. Our answers are honest, but not always appreciated. If you posted personal information, please edit and remove.

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

New Member

 • 

3 Messages

do you have and s10

New Member

 • 

2 Messages

Yeah I just started having the issues within the last 2 - 3 months. I have has S10 plus since release day and never had a problem. Then out of nowhere this crap started.

And it is fine android to android and android to iPhone. Only happen iPhone to android, so when a friend with an iPhone sends me a picture. That is the only time I have an issue. I was blaming imessage but now with this info it is clear that it is something to do with att.

Looks like wifi calling is the problem. But as soon as data is re-enabled either by disabling wifi or by using the dev settings everything is works again.

New Member

 • 

2 Messages

Exactly, the issue started happening a few months ago. It did not happen when I first got the S10, as soon as it was released. I enabled Wi-Fi calling that day. I had no issues for months, then suddenly I do not receive images via text message.

For me, it doesn't matter the device type (Android/iPhone) or which carrier (AT&T, Verizon, etc.) is sending me the image via text, it simply does not work when Wi-Fi is turned on. I need to turn off Wi-Fi to receive an image via text message. Soooooooo annoying!

(edited)

New Member

 • 

2 Messages

Same here. Doesn't matter who is sending me an image on what phone or what carrier, they will not come through (90%+ of the time) with WiFi calling enabled and WiFi on. Sometimes they will eventually come through but that could be when my phone reboots overnight or maybe lose wifi connection or something. Not sure or possible to tell but I can quarantee if I'm using my phone on wifi with wifi calling enabled, the image will not download.

Not sure why this is so difficult for Samsung and AT&T to figure out or at least address publicly. One of them broke it and it's been broken for way too long. Can't afford to buy an iPhone and don't want an iPhone but this is aggravating enough to make me consider it.

New Member

 • 

6 Messages

@LizDance40 Shhhhh the grownups are speaking.