Skip to main content
AT&T Community Forums
Announcements
The epic new Samsung Galaxy S21 5G is available for preorder now!
chung_c1

Teacher

 • 

9 Messages

Mon, Sep 16, 2013 3:22 PM

LG Optimus G Pro - problem with GPS turn on with no reason

My wife has been noticed that the LG Optimus G Pro will always enable the GPS during incoming or making outgoing call with the phone.  The problem is causing the phone to drain the battery and there is no way to stop this problem.  I searched the web and some people experience the same problem with no help from AT&T and LG.  Has anyone experience such problem?  Is there a solution?  Some people need to get a replacement phone to attempt fix the problem.  The problem started in late August and it has been progressed without solution.  My wife's phone is only 2 months old and I do not want to get a refurbish phone in such a short period of time...  Is there way to exchange new or other phone after 2 months?  I do not mind to pay a bit more to change it...  I hope there is a solution out there to fix the problem.

Responses

redpoint73

Professor

 • 

3K Messages

7 years ago

I wonder if its related to this:  http://forums.att.com/t5/Android-Discussion-and-Support/Carrier-I-Q-found-on-LG-G2/td-p/3618891

 

Different phone, but also an LG.

chung_c1

Teacher

 • 

9 Messages

7 years ago

Thanks for the link!  I checked my wife's phone and sure it confirmed with Carrier IQ in it.  I will try to contact AT&T customer service to remove or disable the rootkit type malware in my wife's phone.  Do AT&T suppose to load such rootkit type of malware into our phone?  I though the CIQ supposed to be stop!  Are they randomly loaded to varies peoples phone?

redpoint73

Professor

 • 

3K Messages

7 years ago

There has been some media attention, and I think AT&T was removing it from their devices for a while.  But I don't think there is anything to stop AT&T from putting it on their devices again, if they want to.  At least for the time being.

Contributor

 • 

1 Message

7 years ago

how do you remove IQ Check?

Contributor

 • 

3 Messages

7 years ago

This is ludicrous. I want to remove CIQ but I cannot without rooting the phone,which I don't want to do.

Contributor

 • 

1 Message

7 years ago

clicked the link says I do not have accsess

 

Contributor

 • 

1 Message

7 years ago

it will not let me access that link either even after registering but am having this same issue and i would to fix it

Contributor

 • 

1 Message

7 years ago

I had same problem before. I uninstalled/stop all the location related apps and services (included IQagent), the GPS still turning on by itself. When I compared with other phones, I see there is no option selected on Location Access screen on my LG phone. After I selected "Wi-Fi & mobile network location" and turn on the "Access to my Location" without turning on GPS, the GPS option doesn't turn on anymore unless I turn it on manually. Hope it can solve your problem too.

Jack

Tutor

 • 

2 Messages

7 years ago

Past few days i started noticing the exact symptoms captured in the tutle of this pist . Any resolution?

Tutor

 • 

2 Messages

7 years ago

Ok, I have a ckue now. Under location access in settings, turn on 'access to my location', and check 'wifi and mobile network location'. With this setting, the strange gps behavior stops. Surprisingly this fix works ecen if you choose to turn wifi off ... hope this helps

Contributor

 • 

1 Message

7 years ago

I tried to click that link and it tells me that I don't have the privledges to see that post...

Contributor

 • 

1 Message

7 years ago

I need a better answer.  The link above is now blocked, no access allowed, at least for me.  This is the 3rd LG Optimus Pro phone that I know that has this problem.  The issue appears to kick in about a month after owning the phone, at least for me.  AT&T claims to know nothing, although I'm sure they have something to do with the issue.  All phones that I know that have had this problem are all new.  The only solution is to constantly restore to factory, no one has time for that.  Turning on the WiFi setting as suggested in a couple of posts gives them permission to GPS you, which is what I don't want.

 

Any other solutions or answers to this mystery?

 

 

Tutor

 • 

5 Messages

7 years ago

THAT got SOOOOooo Annoying! FINALLY I FOUND the solution!!! Here's what  you do,

1. Click on Settings

2. Click on Apps

3. Click on Android System

4. On the "IQ Agent, Click STOP!

BAM! Works! 🙂

Tutor

 • 

5 Messages

7 years ago

Do these steps:

1. Click on Settings

2. Click on Apps

3. Click on Android System

4. Click STOP on IQ Agent.

 

Worked for me, and my Optimus Pro G 😉

Tutor

 • 

5 Messages

7 years ago

Do these steps:

1. Click on Settings

2. Click on Apps

3. Click on Android System

4. Click STOP on IQ Agent.

 

Worked for me, and my Optimus Pro G 😉

Get started...

Ask a new question