Announcements

For the latest on our response to Coronavirus (COVID-19), click here.

Andre27

Teacher

 • 

19 Messages

Mon, May 6, 2019 2:11 PM

Havent recieved mms messages on my Google Pixel 2 XL since 5/3/19

This started that night, I have a Google Pixel 2 XL on the ATT network. I can’t receive mms but I can send mms. I’m getting the run around from Google and ATT at the moment. I thought this was fixed in the April 2018 update last year but have seen various posts across here, Reddit and XDA of this issue being prevalent. What I’ve found that works was disabling “Enhanced 4G LTE Mode” in the mobile network settings. I've never had to disable that until now, before Friday I was receiving mms with that enabled no problem. This is the security bulletin that says the issue was fixed and a representative here confirming it at that time. 

Responses

Contributor

 • 

1 Message

a year ago

I started experiencing this same issue late last week.  I'm also running Pixel 2 on AT&T network.  

Contributor

 • 

1 Message

a year ago

My wife has had the exact same symptoms on her Essential PH-1 phone since last friday.  Nothing seems to help.

Andre27

Teacher

 • 

19 Messages

a year ago

For me at least as of the May security update and the Google messages app update (V 4.3.097) on Monday I still cant receive mms messages with the enhanced 4G mode on like I used to be able to.

https://source.android.com/security/bulletin/pixel/2019-05-01

https://source.android.com/security/bulletin/2019-05-01

Contributor

 • 

3 Messages

a year ago

Pixel 2 XL on AT&T prepaid. Same problem. I've been sending myself multiple picture MMS in a row from my Verizon work phone and about one fifth of the pics eventually make it through

Tutor

 • 

7 Messages

a year ago

Same issue here.  I just posted a new thread about it.... Pixel 2, at&t, started just a few days ago.

Contributor

 • 

3 Messages

a year ago

Update -- found the solution on Reddit, user Airtime34:

This is a bug from a year ago that has come back. The current workaround is to disable enhanced 4G LTE mode.  

 

Can confirm, this has fixed it. 

Andre27

Teacher

 • 

19 Messages

a year ago

I've already said that disabling the mode fixes it on the OP. What I would like is to be able to use that feature and be able to get mms like it was doing. I am also seeing an influx of users of Pixel 2 having problems with group messaging.

Contributor

 • 

3 Messages

a year ago

That's true, it's not a clean solution. I'm on prepaid and thus unable to use enhanced call features (AFAIK) so it's a little different for me 

Andre27

Teacher

 • 

19 Messages

a year ago

Anyone know If ATT has said anything?

Andre27

Teacher

 • 

19 Messages

10 months ago

I don't see any reports of Pixel 1,3,3A's having this issue. Seems to be only with the 2 line.

Andre27

Teacher

 • 

19 Messages

9 months ago

I am still having this problem after the last two monthly updates.

Andre27

Teacher

 • 

19 Messages

9 months ago

Anyone else still having this problem?

AT&T TV – All Your Entertainment In One Spot.  Learn more…