Skip to main content
AT&T Community Forums
Announcements
The epic new Samsung Galaxy S21 5G is available for preorder now!
Z

New Member

 • 

7 Messages

Mon, Aug 10, 2020 6:15 PM

Group Texts being sent to each member individually by SMS

I'm using a brand new Sony Xperia 1 II running Android 10 and the stock google text app is sending all my group texts out via SMS individually, rather than via MMS to the entire group together.

 

In the Settings menu, under advanced, my Group MMS setting is not listed.  If I take out the Sim Card, the Group MMS settings under Advanced REAPPEAR.  My old phone (with same version of same app) still shows that setting.   

 

I'm using a third party app, but it's crummy compared to the native one and I want to use the standard android/google apps.   Is there a firmware update that will address this?   Clearly it's got something to do with my SIM, given the option is there until I get onto the AT&T network.

Responses

Brand User
ATTHelp

Community Support

 • 

144.9K Messages

5 months ago

Hello, @zero_vertical,

 

Thank you for reaching out. Your Xperia is an unlocked, non-AT&T branded device correct? If so, Advanced Messaging is not currently supported on through AT&T.

 

You should be able to use MMS messages. Try these steps:

 

  1. Slide up from the bottom menu.
  2. Select Settings.
  3. Select Network & Internet.
  4. Select Internet settings.
  5. Select Accept.
  6. After the download finishes, select Mobile network.
  7. Select Advanced.
  8. Scroll to and select Access point names.
  9. Select New APN.
  10. Enter MMS information as found on the APN settings page.
  11. Select Menu.
  12. Select Save.

Let us know if this helped.

 

James, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

New Member

 • 

7 Messages

5 months ago

Something's not right with that.  My previous phone was an unlocked device that I used with ATT as well.   It's the prior model Xperia 1 by Sony. 

 

When I put the SIM card in that phone, the option on the advanced menu appears, allowing me to use group text.

 

  So clearly, ATT does offer Advanced Messaging for unlocked phones, because I can stick the SIm into my other phone with the same version of android, same app, and same version of the app.

 

Right now, my MMS does appear to be working.  It's just that the "Group Messaging" section in the app's "Advanced" menu disappears as soon as I put the sim card in.   The menus are otherwise identical between the two phones/apps (and again, on this phone, the option is there with the SIM card removed.)

 

(edited)

New Member

 • 

7 Messages

5 months ago

Just confirming that my MMS is working otherwise.   I did make one tweak to the APN (my APN Type also included "fota" in the list, which I deleted), but I still do not have the Group messaging section of my advanced options, and my group strings only send SMS to each participant separately.

New Member

 • 

7 Messages

5 months ago

Just checking back in here.   As I noted, I have multiple unlocked androids on AT&T that allow the group messaging, so there's got to be some other reason this setting is getting locked out when I install the sim card.

New Member

 • 

7 Messages

5 months ago

Following up again.  After speaking with Sony Mobile and Android/Google, it appears the AT&T decided to turn this feature off on certain phones arbitrarily.   

 

All of my prior unlocked Sony phones running Android and on AT&T were allowed (and still are allowed with the same SIM) to have group messages.   Is AT&T planning on fixing this?   From what I now understand, this is a very simple fix on AT&T's end.   

 

 

GLIMMERMAN76

ACE - Expert

 • 

21K Messages

5 months ago

ATT is not sony phone friendly.  You also have to remember your phone will cease to work after Feb 2022 because ATT does not support VoLTE on Sony phones.  Group MMS being blocked is stupid because its not part of advance messaging.

Award for Community Excellence 2020 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

New Member

 • 

7 Messages

5 months ago

AT&T has been very Sony friendly.  My last 4 Sony phones all worked fine on AT&T including:

 

Xperia 1

Xperia X Compact

Xperia Z3 Compact

Xperia Z1 Compact

 

So literally right up until the just-prior generation, Sony phones were fully functional on AT&T, and perfectly "friendly."   This is a new issue that is exclusive to the new, current generation.

 

I'm aware of the upcoming changes with VoLTE, but for me that's long enough into the future that I'm not making decisions based on that.  For the next 2 years, I'd like my flagship phone to work as advertised on this network.

 

This is a simple fix for AT&T, and it doesn't make sense to not do it.  It's literally something they affirmatively had to remove, which was in place on the exact same app, app version and OS on the phone I just took the sim out of.

(edited)

New Member

 • 

1 Message

8 days ago

I'm experiencing the same exact issue with my new(er) XZ3 on T-Mobile. My previous XZ2 worked fine (and still does). Based on all my research, I believe the issue has to do with the firmware. My ZX3 is the HK (Hong Kong) version, where as my XZ2 was the US firmware version. It's our faults for being loyal to Sony and going out of our way tp purchase their international phones. Lesson learned.

Get started...

Ask a new question