Skip to main content
AT&T Community Forums
Announcements
Don’t miss your chance to add AT&T Protect Advantage. Peace of mind, starting at $15 per month. Open enrollment ends 8/31. See all protection plans.

Contributor

 • 

2 Messages

Fri, Mar 16, 2018 6:24 PM

Can’t send or receive text (MMS) messages or picture attachments?

I have tried everything I can think of (including taking the SIM card out and putting it back in) to get picture messages to come through. Even sending then to myself doesn't work. It either doesn't come through, or I get a notification that the message is downloading, and then a message that it failed to download (more often than not, it's just not coming through at all). I can't find anything in the forum that addresses the issue with this specific model. Regular texts work just fine, but I can't get my picture messages. As far as I know, it's only been this week, but who knows how many I haven't gotten or how long it's been going on. Please help!

Responses

Brand User
ATTHelp

Community Support

 • 

127.2K Messages

2 years ago

Greetings @Jennfall,


I’m sorry to hear about the trouble with MMS! I can certainly help you.


Reseating the SIM is a great way to fix this kind of problem. I recommend turning off the cellular data within the phone’s settings and turning it back on to refresh the connection – MMS does require a data connection to send and receive.


If you continue to have this problem, please check out the Troubleshoot and Resolve Tool. It is a great way to fix this kind of issue. I will also be watching this thread, if you need further assistance, please reply! I am confident this can be resolved.


Have a great day.


Adrian, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
JohnInKY

New Member

 • 

26 Messages

WHY does MMS requite DATA to be turned on with AT&T? I used wi-fi to SUCCESSFULLY send and receive both SMS and MMS text messages with photos or videos attached on Verizon for many years BEFORE I screwed-up and switched to AT&T. Now I cannot send ANY texts with photos or videos attached to any non-AT&T user with data either ON or OFF!!

To me it sounds like a design FLAW, or an intentional way to sell more data!!

Contributor

 • 

2 Messages

2 years ago

I tried resetting the data connection, and tried the troubleshooting tool prior to asking my question here. I did go through the forums for the same issue and tried some of the solutions even though they weren't related to my specific phone model. I was hoping to find a solution that didn't involve a factory reset (it's the only thing I haven't done because it's so time consuming, and frankly, a pain in the rear). I've even tried resetting the network connection. I'm not sure if this issue is related to the latest system update (8.0), and their changes with messaging. If so, a factory reset may not even resolve the issue? 

AWA413

Tutor

 • 

53 Messages

Been like this for years. It is AT&T's issue and they don't know how to resolve it. I thought I had it resolved at one point, but it didn't last very long. I thought it had to do with the APN Settings (and still may). Then I figured out the preinstalled app "Lookout" (which you can not uninstall, btw) was the culprit because after I shut it off the issue was resolved! I've made many very detailed posts here about this issue - just click on my user name to see them. I've figured out that it IS indeed AT&T bug. I've been with AT&T Mobility since the beginning - 34.5 YEARS, and I'm now over it. I want a new phone and new carrier. This is AT&T's way of getting you to buy a new device, because believe it or not, even though I've stated twice it is AT&T settings & network, you won't have this issue with a new device. For other details, see my posts. Oh, and by the way, that previous response you got from AT&T was your LAST response from them. They will Not be back here to help you or contribute anything else to this topic, so don't bother waiting on them. They don't care, have moved on, and don't even know how to fix their own issue, unless it requires you to reset your device - which is a huge headache. I refuse to accept that resolution and will not reset my device (Samsung Galaxy S7 Active).

(edited)

Contributor

 • 

1 Message

a year ago

As of 3/18/19, this seems to be an ongoing issue since at least 3/8/19.  I've been to the AT&T store twice and on the phone with tech support four times over the past week.  They assure me it has been elevated and is being worked on.  No resolution so far.  We've tried every possible setting/reboot combination, swapped SIM cards, put the SIM card into another phone, only to have the same issue.  FWIW, I'm on the unlimited plan with a new Note 9; family members on iPhones are not experiencing the same issue.

AWA413

Tutor

 • 

53 Messages

Hi, sorry to say but they didn't elevate it nor will they fix it. I would try and return the device and then see how fast they actually do SOMETHING.

New Member

 • 

18 Messages

Hi, was the problem ever resolved? I am facing the same problem and it's been 3 weeks and no resolution. AT&T keeps opening and closing cases without resolution. Don't know what to do.

New Member

 • 

1 Message

Same here.....I've been having this issue the past couple months, out of nowhere :/

Tutor

 • 

4 Messages

a year ago

Don't factory reset, I'm having the same problem and this isn't the first time. It's a problem within AT&T they refuse to acknowledge. I've had a tough go-around trying to get honesty out of the technical side and the store level employees simply don't know enough of what's going on. Shopping around with competitors because enough is enough.

AWA413

Tutor

 • 

53 Messages

Good for you! Because they aren't going to address this until everyone takes their devices back and cancels their plan. They simply do not know how to fix it and/or don't care.

Tutor

 • 

2 Messages

a year ago

I have been having this issue on and off for two years no.  ATT says it is iphones issue not theirs.  This is not correct.  I have been through hours of testing with Apple and it has been proven to not be their issue due to test we have run on phone.  I am on the phone with them now and I have been transferred SIX times!!!!  I need a new carrier ASAP.

AWA413

Tutor

 • 

53 Messages

It is NOT iPhone at all. Not even close. It is entirely AT&T. I would Love to see a (Edited per community guidelines) suit!

(edited)

AWA413

Tutor

 • 

53 Messages

Oh my, I was edited for typing [EDITED per Community Guidelines]

(edited)

JohnInKY

New Member

 • 

26 Messages

Was it, "EDITED per Community Guidelines?" If so sounds like a good idea. Cell phone chasers, in addition to ambulance chasers?!?!?

(edited)

JohnInKY

New Member

 • 

26 Messages

C A L S

L C A U

A T W I

S I __ T

S O

__N

Apparently, AT&T dislikes the above term................

(edited)

Contributor

 • 

1 Message

9 months ago

My husband and I both got the Note 10 Plus a couple of months ago and I am having this issue. So far, he has no issues with his phone, but I have to restart my phone each time I receive an MMS message before the message will come through. I have tried every possible solution found online and nothing fixes the problem. My husband and I have also compared setting between the 2 phones and everything is set up exactly the same.

New Member

 • 

1 Message

I have the same phone and the same issue. I've tried everything. Has yours resolved?
AWA413

Tutor

 • 

53 Messages

Instead of rebooting your phone everytime, just shut off your Wi-Fi on your phone, the "retry" the download, or click on the photo after the spinner stops. Give it several seconds and the message/photo (MMS) should come thru. Then turn back on your Wi-Fi again on your phone. 😁
JohnInKY

New Member

 • 

26 Messages

We shouldn't have to "hoop jump" and use costly DATA to do this task that is SIMPLE on other networks!! And in Jessig0328's case with BREND NEW PHONES!!!

Tutor

 • 

4 Messages

9 months ago

I’m responding to your AT&T forum post. I got so fed up when no explanation
was given after it happened back to back weeks (as I was getting ready to
leave for a trip). I ended up switching to Verizon and my problem instantly
went away. It’s been 6 weeks so for one VZW and not one issue. The process
to switch was like a bad divorce as well, just overall not fun. It’s a
little more with Verizon but I had enough. Just my thoughts. Good luck,
hope you get an answer
AWA413

Tutor

 • 

53 Messages

Anyone who switches carriers will have this issue resolved. Good job.

Contributor

 • 

1 Message

8 months ago

I had the exact thing happen to me when I purchased the IPhone 11 two days ago. I could receive but not send any pictures. I was SICK of AT&T’s poor customer service and lack of knowledge so TODAY I switched to Verizon!!! It was the best decision EVER! Instantly, I can receive AND send pictures. I had the best experience switching AND they gave me a $250 gift card for switching to them!!!!! Bye AT&T!!!!! 

New Member

 • 

3 Messages

Same issues. I think I'm switching to Verizon

Contributor

 • 

1 Message

8 months ago

I have all Samsung phones with my family (3) in total. Having same intermittent problem with pics not being received or sent for last 3 weeks or so. They told me reconnect my phone for updates which i did. still have issues. I was going to call again tomorrow but maybe i should just calll verizon instead.  #ATT. 

AWA413

Tutor

 • 

53 Messages

You should call AT&T and report the problem, then cancel your service after your conversation - NO MATTER what they say. It will fix the problem.

New Member

 • 

3 Messages

4 months ago

I can't send pics to people anymore and in group texts, people in the group get my texts a whole day later. I may switch and I've had AT&T FOR YEARS

Tutor

 • 

1 Message

4 months ago

I'm having the same problem (sort of). I have a Galaxy S10, my mom has one as well, my husband has a Galaxy S8. We are all on the same phone plan through AT&T and have been since 2000. For the last few weeks my mom and I have been having issues with the images coming through via text... I can receive pictures from her, but she can't receive any from me. She was the only person I was having this issue with. Now this week it started happening when I sent my husband photos. I can receive images from him, but all he gets from me is an error message. This is beyond aggravating and from what I've been reading the only fix is to change providers altogether. I'd hate to do that because we've never had any issues until now, but it looks like it may be time.

New Member

 • 

3 Messages

I know - i LOVE AT&T and have been with them for almost 20 years as well. I never ever EVER had ANY PROBLEM until now. It really makes me sad, but I agree - it looks like it is time. :(

AWA413

Tutor

 • 

53 Messages

Everyone needs to shut off their Wi-Fi in order to receive mms messages, and eventually maybe pay AT&T for moble data charges, OR, switch carriers to completely fix the problem. AT&T are not doing anything about this and it doesn't look like they care enough to either. I've been dealing with this issue for quite some time which is why I have so much to say here, on this post. Need a (Edited per community guidelines) suit. Maybe I'll look into that soon. If we aren't getting what we pay for, then it would be nice for everyone here and everywhere to get a nice fat reimbursement for money lost, time, trouble, and suffering! Who's in? 🤔😎

(edited)

AWA413

Tutor

 • 

53 Messages

Edited again? Interesting ...

I guess you can't type anything that refers to a legal proceeding in which persons representing interests common to a large group participate as representatives of the group (or class)?
AWA413

Tutor

 • 

53 Messages

4 months ago

Oh jeeez. I'm such a (Edited per community guidelines). I didn't realize until just now this post was 2 years old. I thought it had just posted.. 😖

(edited)

JohnInKY

New Member

 • 

26 Messages

Same here! Seems like some things NEVER change, OR get resolved!!!

(edited)

JohnInKY

New Member

 • 

26 Messages

4 months ago

I have a VERY similar problem! I can RECEIVE text pictures form others including non-AT&T users, but CANNOT SEND any text pictures to any one OTHER than AT&T users. I switched from Verizon 3/11/2020 have had this problem (and NO wi-fi calling) ever since. BIG mistake switching!!

Click on my forum name above to see my entire saga on this issue......

Good luck!!!

(edited)

New Member

 • 

1 Message

Was your phone purchased from AT&T? If it was purchased elsewhere unlocked, this could be the issue. I purchased mine unlocked directly from Samsung and have been having this issue ever since. I also can't use the calls over Wi-Fi feature.
JohnInKY

New Member

 • 

26 Messages

Phone(s) originally from Verizon and switched to AT&T 3/11/2020. TROUBLES ever since. BIG mistake switching, but likely Verizon data breech got my account hacked and bunches of iPhones were being purchased on my account over-and-over. So, had to close and switch. AT&T was a REALLY BAD CHOICE!! Now in the process of switching to Spectrum Mobile to hopefully END the AT&T disaster........

New Member

 • 

1 Message

I switched to AT&T from Verizon in March and have a very hard time sending photos via text. Sometimes it works, sometimes it doesn't. I bought a Note10+ from AT&T when I made the switch, so I don't think the issue is related to where the phone came from. I regret making the switch even though I am saving $ compared to what we were spending with Verizon.

New Member

 • 

1 Message

I went into advanced settings under my wifi connection and set the metered network to unmetered and I'm able to send pics now. Galaxy S20 Ultra. I then changed my wife's S8 Active and now she's able to send pics too.

New Member

 • 

2 Messages

You all need to check your APN Type in your Network..... For AT&T 2020 revision the APN Type must read as:

 

default,mms,supl,hipri,forta

 

I had the same issues and went into my APN and corrected this section of APN (APN Type) and now I am able to send all Multimedia attachments. Hope this helps anyone that is experiencing issues. 

New Member

 • 

13 Messages

2 months ago

The problem is a serious one and not only you and me but plenty of people have reported about this error. Its really irritating that we are not able to send pictures messages on Android. But there is nothing to worry about as some ways available to solve can't send picture messages on Android.

Some of the fixes are:

  • Restart your device
  • Check whether MMS is enabled
  • Check signal strength
  • See if data plan is activated
  • Wipe data and cache of messaging app
  • Do factory reset.

All these are some effective ways to fix can't send or receive picture messages on Android.

See more on: https://www.androiddata-recovery.com/blog/fix-cant-send-picture-messages-android

 

New Member

 • 

1 Message

I've done all the basic troubleshooting, I'm beyond done with random blocks not being able to text a basic picture. We are waiting for these phones to be paid off and immediately switching back to Verizon. 

New Member

 • 

2 Messages

a month ago

AT&T is correct. I'm not an AT&T representative but if your having issues with sending any MMS attachments I would highly suggest looking into your Network and within your APN in APN Type I corrected the entry and I can now send pictures and videos once again. In your APN Type it must read as follows.

 

APN Type

default,mms,supl,hipri,for ya

 

Doing this exactly corrected the issue.

 

Hope this helps... 

New Member

 • 

1 Message

The problem just started this morning for me.  I was not able to send any pics or gifs, but could receive them.  I have Note 9. My son has same phone.  He did not have this problem. I just followed these steps.  Problem resolved.  I had to go fix a few messaging settings, but was instantly able to send gifs and pix.

Here's how you do it on your Note 9:
  1. From the Home screen, swipe up on an empty spot to open the Apps tray.
  2. Tap Settings > Apps.
  3. Tap the desired application in the default list.
  4. To display preinstalled apps, tap Menu > Show system apps.
  5. Tap Storage > CLEAR CACHE > CLEAR DATA > DELETE.
Jun 17, 2020

Samsung Galaxy Note 9: Safe Mode, Wipe Cache Partition 

Get started...

Ask a new question