Skip to main content
AT&T Community Forums
Announcements
Don’t miss your chance to add AT&T Protect Advantage. Peace of mind, starting at $15 per month. Open enrollment ends 8/31. See all protection plans.
balst01

Teacher

 • 

11 Messages

Fri, May 17, 2019 9:16 PM

Call forwarding just does not work

I have had a perennial issue with call forwarding for the last 2 years and it has become a real pain, so I'm looking to finally solve it this time, if one of the AT&T support guys can help. Each time I go abroad, I want to just forward my wireless number to another line (in the U.S.) and turn off my phone, but up to this point it has never worked. I have a Samsung Galaxy S8+, and have tried both of the following methods:

 

  • **21*[number]#
  • Go to settings->Supplementary Services->call Forwarding->Always Forward, turn on and add the number

Both methods have exactly the same effect, they say that the phone has been forwarded unconditionally (MMI is successful), and I even get an icon in my notification panel stating that call forwarding is on unconditionally. Now my phone never rings.

 

So, here's the problem....if I call my number from another phone it just goes straight to voicemail. I have tried all of the following with no success:

  • Leave the phone switched on and on the network: It doesn't matter how long I leave it on for, the call forwarding never goes anywhere, all calls just go directly to voicemail, and not to the number I forwarded to
  • Turn the phone off completely....same as above, it doesn't help
  • Forward to several different numbers including another AT&T wireless number and even a landline...It doesn't matter where I try to forward to, as soon as I turn on call forwarding all incoming calls just go directly to voicemail and not to the number I forwarded to.

Am I missing something here? As far as I can tell, call forwarding just plain doesn't work on AT&T, any attempt to turn on call forwarding will say it is on and then just forward all calls directly to voicemail.

 

Pleease help, I'm getting desperate.

 

Thanks

Responses

Accepted Solution

Official Solution

balst01

Teacher

 • 

11 Messages

a year ago

After some playing around I managed to fix this problem.

 

The issue appears to be a forwarding priority problem. There are 4 types of call forwarding which are supported by AT&T and most devices, they are:

 

  • unconditional call forwarding
    Forward on busy
    Forward on unanswered
    Forward on unreachable

 

According to some earlier posts in other threads on this forum it is currently impossible to set anything other than unconditional yourself (even for unconditional I'm not sure, although it appears to work), apparently AT&T disabled this some time ago citing security concerns. So, in order to set the others, you need to call 611 and ask AT&T to do it for you.

 

So, to the issue. In my case (and I believe in most cases), the default call forwarding number for all of the various types of call forwarding is the voicemail number for AT&T (starts with 415 area code). What appears to happen if you try to set unconditional call forwarding yourself is that it appears to have worked, but when someone makes a call to the number, AT&T defines the phone to be unreachable, so, instead of forwarding to the unconditional call forwarding number, it forward directly to the unreachable call forwarding number, which is set to the voice-mail number, and the caller is directed immediately to voice-mail.

 

The way to fix this is to change the call forwarding for "unreachable", but as I mentioned earlier, you can't do this yourself; I have tried with both the phone settings and the MMI number (which BTW is very hard to find), both return some kind of error indicating that it cannot be done. So, you need to call AT&T and tell them, very specifically, that you would like to set *ONLY* your "forward on unreachable" to the number that you actually want to forward to. Now, when the caller calls the number, if you have set unconditional call forwarding, or you turn off your phone, or you set it to Airplane mode, or you take the SIM out and go to another country, your calls will be correctly forwarded directly to the "forward on unreachable" number, which is correctly set.

 

I have done this, and it works perfectly...it's easy to test, you just need to put your phone in airplane mode. 

 

To any Google Voice users, I have set mine to a Google Voice number, and it works perfectly. Now, if I have WiFi access in another country, or I put another SIM in my phone that has internet, I will be able to answer calls that come in to my AT&T wireless number on my Google Voice number.

 

Beware that the level 1 staff at the 611 line are completely clueless about this and they will try to send you a link to the set of instructions to do it yourself...they don't work; you need to insist that you want them to do it, and try to talk to one of the wireless experts who can actually set the correct call forwarding at their end. Be prepared with your IMEI number, they asked me for it for both lines.

Brand User
ATTHelp

Community Support

 • 

127.6K Messages

a year ago

Hi, @balst01,

 

We'd love to help with this. When you set up call forwarding before leaving the US, you don't suspend your service for the duration? If so, that would be the reason it isn't working. If that isn't the case, sign into your myAT&T account, go into the AT&T Troubleshoot & Resolve Tool (Call Forwarding), click on Next step, and follow the steps provided. If this doesn't help find the cause and solution, please let us know so that we can investigate further.

 

Have a great day!

 

James, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
loveh2o

Teacher

 • 

17 Messages

9 months ago

Thanks @balst01  - this was informative and it worked.  I too was unable to set up via phone or MMI numbers.  And your explanation of unreachable call forwarding was exactly what I need while traveling internationally with a different sim.  I just had 611 support do it, and now when I check my phone for call forwarding settings it displays call forwarding when unreachable with the correct phone number.  This is a setting that probably is useful to keep on at all times!  Thanks again

loveh2o

Teacher

 • 

17 Messages

9 months ago

Except testing it out - it goes straight to my phone voicemail - so something still not right.  I turned airplane mode on and tried from two different phones.  thoughts?

balst01

Teacher

 • 

11 Messages

9 months ago

I ended up telling them to set everything except unconditional call forwarding to the same number (my google voice number), and as you mentioned, I just leave it like this all the time. So, now what happens is, if I'm in the country and in reception I can answer the phone, but if I don't answer or I am out of reception (or out of the country), it rings my google voice number. The down side it that it will never forward t my AT&T voicemail, even if it rings and I don't answer, what happens now it that it rings 4 times, and then starts to ring my google voice number, and after another 4 rings, google voicemail answers it. I actually like it this way because gooogle voicemail transcribes the message and then sends me an e-mail with the text plus a wav file of the message, which is much better than the AT&T version.

 

I just got back from Australia, and this worked perfectly for me while I was out of the country.

 

One other footnote if you are using Google Voice....you need to change the settings in Google Voice so that it does not forward back to your real AT&T phone number, otherwise the call just bounces straight back to AT&T and ends up going directly to voice-mail....maybe this is your problem. In order to set this you need to use the PC browser interface. Go to voice.google.com and choose "legacy google voice" from the left chevron menu, then choose settings from the menu at the top right. under the "Phones" tab, uncheck "Forward calls to", by default it always seems to try to forward calls to your real number, and with this checked the call will just go directly to voicemail. Be careful, every time you make some change to the phone (like a new SIM), it seems to check this again, so keep an eye on it.

 

Also, back in the non-legacy screen, choose "settings" there, scroll down to "Calls", and under "My Devices" "Turn on devices you want to answer calls on", and make sure your phone device is switched on. This is usually on, but sometimes it can get switched off, and without this on, you phone won't ring when someone calls you.

loveh2o

Teacher

 • 

17 Messages

9 months ago

Thanks - however I'm forwarding to an xfinity 'land-line' (voip) home number.  Which is also where my google voice numbers ring to.  I get visual and email notifications on that number, which is what I wanted to achieve.  Don't have time to debug for this trip - I guess I'll just have to check voicemail by calling my own number and hitting * for this trip.  But your information has been great!

Get started...

Ask a new question