The Samsung Galaxy S23
Jedi71's profile

Contributor

 • 

3 Messages

Thursday, May 21st, 2015 4:28 PM

AT&T LTE situation with US ASUS ZenFone 2 ZE551ML

Not having a micro SIM, and only the nano SIM from my iPhone 6, I went to the AT&T store to get provisioned over to a micro SIM.

 

There the associate decided, without my knowledge, to change my data plan based on the ZenFones IMEI number.

 

Long story short, I no longer have an LTE based data plan. I was on AT&T chat for 2 hours as they tried to explain to me that:

 

  1. Data plans are based on your IMEI number.
  2. They can't change me back to the iPhone plan.
  3. Since the ZenFone is not an AT&T branded phone they can't guarantee LTE service anyway.

Then I mentioned that my iPhone SIM has been receiving LTE just fine in my OnePlus One for 2 months as I tried out Android. They didn't have an answer for that.

 

So they are taking my case to AT&T technical support to see if an LTE plan can be programmed for me. The employees try to tell me that the reason the phone is not getting LTE is because the phones IMEI number dictates the data plan, and so far, the data plan it dictates is only 3G.

 

If this is the case, then ASUS and AT&T need to work together, fast, to program in an LTE plan for ZenFone 2's. Otherwise my plan is to reprovision my iPhone then swapping sims.

 

Anyone else having luck with AT&T giving you an LTE plan to use on the ASUS ZenFone 2?

 

 

Accepted Solution

Official Solution

Contributor

 • 

3 Messages

7 years ago

Since this is still an open post.

 

I just wanted to reply that I was able to easily correct my phone's connectivity to AT&T's LTE network. The APN info in the phone was old, so I input the settings on this page: https://www.att.com/esupport/article.html#!/wireless/KM1062162

 

I no longer had data access at that point, so I clicked the button for chat support. Explained that I input those settings but have no data. They took my IMEI number and sim ID then had me restart my phone.

 

Now my phone works just fine on LTE.

HitShane

Teacher

 • 

32 Messages

8 years ago

You dont need to tell them what the sim is for. Just tell them what size and which line for it to be. Don't even bring your phone in with you.

 

[Inappropriate content removed]

Contributor

 • 

1 Message

8 years ago

Same problem here. Same response from customer service. Jedi71, are you also capped at H+? Would an AT&T rep please advise on how to connect the ZenFone 2 ZE551ML at 4G LTE without resorting to lying about the phone's IMEI # (see http://forum.xda-developers.com/zenfone2/general/4g-lte-confirmed-att-t3073711) or switching carriers?

Contributor

 • 

3 Messages

8 years ago

Yes, exact same problem. I can get H+ data but no LTE. My conversations with AT&T indicate the plan they "had" to put me on is not an LTE plan as my IMEI says it's not LTE capable. At least thats how AT&T sees the IMEI.

 

Even the Asus FAQ on this phone says:

 

If you use AT&T’s monthly mobile cellular data plan on our ZenFone 2 (ZE551ML) and cannot get 4G/LTE speeds with our device(s) only showing HSPA speeds. Please visit AT&T’s website below and contact AT&T to have AT&T provide access on their 4G/LTE networks with our ZenFone 2 (ZE551ML) device(s).

 

http://www.asus.com/support/FAQ/1012017/

 

So ASUS knows there is something about the phone that makes AT&T (T-Mobile was not mentioned) think the ZenFone 2 can't get LTE. But we all know it can if we put in our SIM cards provisioned on other known LTE capable phones.

 

Is that the fix AT&T suggests?

 

 

GLIMMERMAN76

ACE - Expert

 • 

23.6K Messages

8 years ago

to be really candid att could careless about making the phone work.  That is why they pull the you may not get all features when you bring your own phone.

 

I have a nano sim and sim card adapter.  I use it in all my phones when I switch.  I have LTE on my zen 2.  But it was provisioned with my s6 imei number.

Contributor

 • 

1 Message

8 years ago

Does your phone say LTE or just 4G? I'm trying to determine if i'm actually getting LTE on my zenfone 2 but all it says is 4G.

kenster817

Teacher

 • 

22 Messages

8 years ago

Did you ever get the 4g LTE working on the zenphone 2 ? I want one bad but want to make sure it works.

Ken

Contributor

 • 

3 Messages

8 years ago

Yes! I did get LTE working on the ZenFone 2. It only shows a 4g indicator, but they are LTE speeds.

I actually did nothing, I finally got an AT&T rep over the phone that gave me an LTE smartphone plan. This flies in the face of what every other rep told me which was "you have a data plan, and if your phone does LTE, it will get LTE." And of course that is not the case, they have to give you a plan capable of LTE.

Unfortunately the zenfone2 IMEI number still doesn't show that it's capable of LTE, so you have to cross your fingers you get a rep to actually give you an LTE data plan.
kenster817

Teacher

 • 

22 Messages

8 years ago

Thats great. I have a phone that has a micro-sim card with LTE already programmed. Does the zenphone have a micro-sim and would all I need to do is move the sim ? I still don't understand if you are getting LTE why the phone would not display 4G-LTE.

GLIMMERMAN76

ACE - Expert

 • 

23.6K Messages

8 years ago

The phone will display h or h+ for HSPA which ATT calls 4g.  so 4g=LTE in asus eyes now some phones will say just LTE.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.