Announcements
HBO Max - where HBO meets so much more!

Tutor

 • 

5 Messages

Tue, Mar 27, 2018 3:19 PM

App Icon Badge Notification not working after Android 8 Update

Could use some help on this. After the most recent Android update on my S8+ badge notifications on the standard email app no longer worked. Went thru all the menus to ensure that the options were turned on for each email account as well as the master notification were enabled along with the samsung home option. Now when emails come thru the badge shows up with a count of 6 regardless of how many actual new emails there are and notification goes away even when emails are unread. This didn't use to be the case prior to the update. What gives? 

Responses

Lilybell2

ACE - Professor

 • 

1.8K Messages

2 years ago

Clearing the email app's cache may resolve the problem: https://www.samsung.com/us/support/answer/ANS00077289/  

 

 

Note: If your issue has been resolved, please mark the post that resolved your issue as the solution. Select "Accept as Solution" to help others with the same issue find an answer.
Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Tutor

 • 

5 Messages

2 years ago

Gave it a try but the same issue occurs. Sent a test email and the badge shows but again has a 6 digit in the bubble and after not reading the email and exiting the app the badge notification clears although there are unread emails still there. 

Tutor

 • 

5 Messages

2 years ago

Gave it a try but the same issue occurs. Sent a test email and the badge shows but again has a 6 digit in the bubble and after not reading the email and exiting the app the badge notification clears although there are unread emails still there.

Lilybell2

ACE - Professor

 • 

1.8K Messages

2 years ago

You may need to clear the app's data, which would reset it to its original state.  You could first try wiping your S8's cache partition, which will not impact data nor settings, etc.  Wiping the cache partition is something that's always good to do after an update; and doing that is often enough to clear up post-update issues. 

 

 

 

Note: If your issue has been resolved, please mark the post that resolved your issue as the solution. Select "Accept as Solution" to help others with the same issue find an answer.
Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Tutor

 • 

5 Messages

2 years ago

Performed the cache clean and still have the same issue. Showing badge notification with incorrect number and goes away when exiting app.

Lilybell2

ACE - Professor

 • 

1.8K Messages

2 years ago

All I can suggest at this point, short of a factory reset, is to clear the email app's data.   

 

 

Note: If your issue has been resolved, please mark the post that resolved your issue as the solution. Select "Accept as Solution" to help others with the same issue find an answer.
Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Contributor

 • 

3 Messages

2 years ago

I am having this exact issue, except my magic number is 14 rather than 6; i dont have 14 mew emails. Then when I exit the app, which still has 2 new emails, the number bubble goes away completely. This same issue is also occurring on the primary facebook app as well. Ive gonne through every option to allow these badges to operate and cleared all my caches which did not repair the issue. Funny how immediately after the update was completed, the phone showed me a "new feature" pop up describing the badges amd now they dont work anymore. ATT definitely has bugged this update and need to fix it ASAP...

Contributor

 • 

1 Message

2 years ago

Same issue, except my magic number was/is 42.  After I uninstalled the launcher, It doesn't show any notifications when I get mail.  When I reinstall the launcher, it goes back to 42.

Contributor

 • 

2 Messages

2 years ago

Same issue, my magic number is 7, tried clearing the email apps data with no help and also tried clearing the cache partition with no help. Hopefully this will be corrected by AT&T.

Contributor

 • 

3 Messages

2 years ago

Home screen time, date and local temperature not updating now either...

Lilybell2

ACE - Professor

 • 

1.8K Messages

2 years ago

It is possible a factory reset may help.  Be sure to backup important data first. 

 

 

Note: If your issue has been resolved, please mark the post that resolved your issue as the solution. Select "Accept as Solution" to help others with the same issue find an answer.
Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Contributor

 • 

3 Messages

2 years ago

I considered doing a factory reset but the Androids don't take a mirror image of the phone settings like iTunes does. Even though ill have all my data backed up, it takes me 2 or 3 hours to reset everything how I had it. I haven't performed a reset in over a year but that's what I had to do last time...did they improve the process any?

Tutor

 • 

5 Messages

2 years ago

So caved this morning and did factory reset. No issues with the badges this far. However the system doesn't not maintain the badge once the app is accessed regardless of if email is read.

Lilybell2

ACE - Professor

 • 

1.8K Messages

2 years ago


@jde215 wrote:

So caved this morning and did factory reset. No issues with the badges this far. However the system doesn't not maintain the badge once the app is accessed regardless of if email is read.


It's standard behavior for a badge count to vanish after the associated app has been accessed even though the email has not been read.  The objective is to notify you of new emails, not maintain a count of unread emails. 

 

 


 

Note: If your issue has been resolved, please mark the post that resolved your issue as the solution. Select "Accept as Solution" to help others with the same issue find an answer.
Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Contributor

 • 

2 Messages

2 years ago

Tried the factory reset, did not help my problem, still shows 7 on the email badge when ever I receive an email. After opening it goes away.