Our Community Forum will be shutting down on June 27, 2024. Please visit att.com/support for all your support needs.
The Samsung Galaxy S24
mmcnama5's profile

Tutor

 • 

6 Messages

Tuesday, July 8th, 2014 5:07 AM

APN settings for my OnePlus One

Just got a OnePlus and it is defintiely LTE compatible based on the device specs (says it is bands 4/17 compatible). 

 

Now, when I spoke w/ ATT on the phone they said the device may not work at LTE speeds. From what I'm reading online, this is because the SIM I'm using has never been registered on a LTE network. 

 

Users of other unlocked phones have mentioned this is an issue and have suggested the following: 

Put the micro SIM in a compatible LTE phone and turn it on. The SIM should register on the network. Put the SIM back in the unlocked phone and you should be good to go. 

 

To test that I'll have to find a compatible phone, but so far changing the APN settings hasn't worked. 

 

Any thoughts from ATT or otherwise?

Accepted Solution

Official Solution

Former Community Manager

 • 

10.4K Messages

9 years ago

 

Hi everyone,

 

There is also a support article with the APN settings for non-AT&T devices located here. And as always, if you have any other questions, feel free to post them and the community will be happy to help!

 

You can also see more information on what is needed when bringing an unlocked device to AT&T here: Bring your phone or tablet to AT&T

 

Thanks,

Dmitriy

Guru

 • 

450 Messages

10 years ago

Hi @mmcnama5

 

Based off the specs of your device, you should be in the clear for LTE data service to work on your device as long as you have LTE service in your area. There are two things that you need to check on. First make sure your APN settings are set to the latest, most up-to-date APN settings. You can find the most recent APN settings by clicking Here

 

Second, you need to make sure that your data plan is reflecting an LTE enabled device. I have not personally delt with the OnePlus One device, but tech support should be able to get your plan set up for LTE data if it isn't already set up. You can check if you have an LTE data plan by logging into myAT&T.

 

Hope this helps!

 

 

Tutor

 • 

6 Messages

10 years ago

Appreciate the response! I am sure LTE is available in my area.

 

When I have the APN you linked to selected my device says "No Internet Connection." I can make calls and text, must no data. 

 

If I switch the APN "ATT Phone" with these settings:

 

APN: phone

Proxy/Port/Username/Password/Server: Not set

MMSC: http://mmsc.mobile.att.net

MMS Proxy: proxy.mobile.att.net

MMS port: 80

MMC: 310

MNC: 410

Authentication type: Not set

APN type: default,supl,mms

APN Protocol: IPv4

APN roaming protocol: IPv4

Bearer: Unspecified

MVNO: none

 

Then I get data (looks like HSPA to HSPA+ speeds). 

 

To the second part of your response, when I called in they said that because the phone is unlocked and the IMEI doesn't show on their system, therefore they can't guarantee LTE Speeds. The system actually said it was putting me on a 2G plan.

 

Thanks! 

Guru

 • 

450 Messages

10 years ago

Hi mmcnama5, 

 

I apologize you're still having issues with your device. I personally had this problem before a long time ago with an old blackberry. The issue is your account thinks that you have a 3G/HSPA+ device as our default data plan. 

 

You can reach our to our Tech Support line (1-800-801-1101). They need to manually change your data plan to an LTE data plan. A store won't be able to though their system will only populate a data plan off the IMEI of your device. You can say you have an unlocked pure Android device (Nexus 5, or a Google Play Edition of a device) and they should be able to get you squared away. 

 

You can also send a PM to ATTCustomerCare and they can assist as well. You can expect a response from them within 2 business days. You can send them a PM by clicking here.

 

Hope this helps!

Tutor

 • 

6 Messages

10 years ago

So I just got off the phone with tech support. He tried linking the phone
to an LTE plan, but said he was unable to. Ultimately, he reverted back to
"This is an unlocked phone with an IMEI that the system doesn't recognize
and we cannot guarantee LTE."

Not sure where to go from here.


Matt

Tutor

 • 

8 Messages

10 years ago

Matt,

 

Can't speak for others, but the settings you provided above for AT&T Phone APN did the trick for my OPO.  Got connected HSPA at first, but after a minute or so the 4G sign showed up.  I use GoPhone SIM and was previously using an international (non-LTE) Samsung S3.  I first tried to get help in the local store, but they had no clue.

 

Only trick for me was remembering to save the APN settings through the top right button - if you simply go back it loses changes.

 

Thanks,

Mike

 

Tutor

 • 

8 Messages

10 years ago

I should add - they did add my IMEI number to my account in the store.

Tutor

 • 

6 Messages

10 years ago

Thanks. Ultimately, I got mine working in a local store. Been loving it.


Matt

Contributor

 • 

1 Message

10 years ago

Hi, curious what type of plan you're on?

 

My OPO is in the mail on its way to me. I'm using a feature phone plan now at $50/mo all unlmited.

Tutor

 • 

6 Messages

10 years ago

Originally it was an unlimited plan, but the week I got my phone we
switched the family plan to the next program and so we now have 6 phones,
10gbs of data, etc.

Everything is now working without issue. Full LTE and what not. Great phone.


Matt
Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.