5GB of Hotspot Data With an Unlimited Plan
Cynycole's profile

New Member

 • 

2 Messages

Sunday, September 18th, 2022 6:00 AM

SIM CARD DISCREPANCIES

I bought a replacement phone for my ATT prepaid account, the previous phone screen broke and so I needed another. When I placed my current, active SIM card into the new phone, the SIM status displayed that the card and service was active, but there was an X through the service indicator. I called ATT and a recorded line informed me there was a problem during activation and that I needed to bring it back to the retailer in order for them to activate the phone. I did this and ended up exchanging the phone with a new one of the exact same model, and found myself facing the same issue. I used my wife's active SIM card in the new phone, in place of mine, and the service worked fine. When I placed my (original, working) SIM card into her working phone I got the same error as before. So obviously the problem isn't the activation with the retailer rather it's present within the SIM card itself but I don't know what exactly it might be. 

ACE - Sage

 • 

104K Messages

4 months ago

It doesn't sound like there's anything wrong with the phone, but it does sound like perhaps you have PUK locked your sim card. A PUK lock prevents the SIM card from being stolen and used in a different phone. You can find the PUK code in your online account or you have to call AT&T to get it. If they cannot find a PUK code you will have to have the SIM card replaced.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.