Skip to main content
AT&T Community Forums
T

New Member

 • 

4 Messages

Sat, Sep 19, 2020 3:24 AM

$300 plan

I signed up for the $300 8GB plan. I received the SIM card. It says it is activated. But I haven't been charged for the plan and the next step to activate on the phone doesn't list a plan. I can't get through to any AT&T person to help me on the phone. The automated phone system hangs up on me because I don't have an account. If I put the sim card in my phone it won't let me call 611. No other person on any other AT&T phone number will help after calling 5 different numbers a total of 20 times and trying every option. I just get referred to the prepaid number which says wait times are long so choose an automated option and there is no option that can help and it hangs up on me after it doesn't like the phone number or SIM number that I give it. The AT&T Store can't do anything beyond seeing what I already saw online. I found the port URL and it says it is confirmed. This is the worst experience I have every had with any company in my life. Is there any possible way to talk to someone at AT&T or get some help?

Responses

New Member

 • 

8 Messages

2 months ago

Right, I understand that. It was just impossible to even get through to customer service and when I finally resorted to Facebook, they redirected me back to the prepaid page with no options but to call. Seems like they should have an alternative customer service route considering some people are out a phone or service when they sign up. I'm sure I'm not the only one. Especially during times like this, to have to go into a store just to get my questions answered, plus the error with 4 attempts to pay/ said payments not registering... I have just never had such a hard time with a phone company.

Get started...

Ask a new question