Contributor
chall77
Posts: 1
Registered: ‎02-20-2013
Activating Microcell w/ Comcast home internet

We recently moved to a condo that is pre-wired for Comcast home internet service (I believe it is the xFinity service). In trying to set-up our Microcell, we have been unable to activate. We have it connected to the Comcast modem via ethernet. We get three solid green lights and a blinking green light at bottom. 

 

I did a bit of searching these forums and elsewhere online and don't see anything that specifies that Comcast would be blocking the traffic from an MCell.

 

Am I doing something wrong? I'd like to avoid having both parties pointing the finger at the other and not get anywhere.

 

Any advice?

 

Thanks!

Otto Pylot
Posts: 3,229
Kudos: 146
Solutions: 26
Registered: ‎03-20-2011
My Device: iPhone 5
Re: Activating Microcell w/ Comcast home internet

Connecting directly to the modem (modem -> MicroCell) is called priority connection and rules out any router issues if you are using a router. It's used mostly for troubleshooting but some folks prefer to be connected that way. Nothing wrong with it. The blinking green 3G light either means the MicroCell is waiting for activation or there is something blocking the connection to the AT&T servers (if its a port, it's usually 4500). I'm assuming you have gone thru the activation process and are awaiting confirmation. The location address of the MicroCell needs to be the same address as the AT&T primary account holder, so if you've recently moved maybe AT&T doesn't have  your new address in their database yet.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Tutor
Woodister
Posts: 6
Registered: ‎02-22-2013
Re: Activating Microcell w/ Comcast home internet
I'm trying to get the microcell to work with Comcast as well. The activation process has been completed and the address is fine. I've had it hooked up to my router for 24 hours, all the lights on the microcell are solid green but the 3G and well computer but I don't have one hooked up to it. Thinking it was the router I hooked the microcell directly up to the modem for 2 hours and am still just getting the flashing 3G. Is there something with Comcast that is the issue or the modem? The modem is an Ambit.
Posted from Apple iPad
Tutor
Woodister
Posts: 6
Registered: ‎02-22-2013
Re: Activating Microcell w/ Comcast home internet
Digging deeper I went to the modem config page and see that fragmentation is enabled but there is no setting to disable this option even when logged in as admin.
Posted from Apple iPad
Tutor
Woodister
Posts: 6
Registered: ‎02-22-2013
Re: Activating Microcell w/ Comcast home internet
Sorry for all the posts, but it is working now. I read on some other forums that comcast's network is screwy and the IP address you get defines if your microcell is going to work. So I renewed my IP address until I got one in the 70.xx.xx.xx range and it worked. Weird.
Posted from Apple iPad
Tutor
Woodister
Posts: 6
Registered: ‎02-22-2013
Re: Activating Microcell w/ Comcast home internet
<sarcasm>This thing is awesome!</sarcasm> tried to make my first call and it instantly dropped and I'm back to my 3G light blinking.
Posted from Apple iPad
Otto Pylot
Posts: 3,229
Kudos: 146
Solutions: 26
Registered: ‎03-20-2011
My Device: iPhone 5
Re: Activating Microcell w/ Comcast home internet

Ok. If the 3G light is blinking green, then you don't have connection to AT&Ts servers which is obvious because your phone doesn't work. The IP address is odd. Is your Comcast connection with an all-in-one modem (gateway and router) or do you use a separate router? Either way, you should be getting a useable IP address assigned to the MicroCell via DHCP. It sounds like a configuration issue. I assume that the MicroCell is within 18" of a window with an unobstructed view of the sky and about 2' away from a WiFi source. See the link in my sig for the MicroCell Troubleshooting Guide.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Tutor
Woodister
Posts: 6
Registered: ‎02-22-2013
Re: Activating Microcell w/ Comcast home internet
The device is sitting on my window sill and is about 4 feel from the router. I have a Western Digital N750 router and ambit u10c018 cable modem. I've tried the priority hook up and plugging the microcell directly to the modem to no avail. The ip theory seemed strange to me too and was proven incorrect when I lost signal after trying my first call and it never coming back.
Posted from Apple iPad
Otto Pylot
Posts: 3,229
Kudos: 146
Solutions: 26
Registered: ‎03-20-2011
My Device: iPhone 5
Re: Activating Microcell w/ Comcast home internet
Ok. All lights are solid green except for the 3G, which is blinking green. Priority should work because that's a straight connection to the Internet. Ask Comcast if they are blocking any of the ports listed in the troubleshooting guide. Unlikely but you never know. IPSec Pass-through has to be enabled (should be default for Comcast) and Block Fragmented Packets has to be disabled (I think, but the correct config is given in the Guide). If your router is placed between the gateway and Microcell, NAT has to be enabled on only one device.
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Posted from Apple iPhone
Tutor
Woodister
Posts: 6
Registered: ‎02-22-2013
Re: Activating Microcell w/ Comcast home internet
In the modem config page it says fragmentation is enabled, but there is no setting to disable it.
Posted from Apple iPad
Otto Pylot
Posts: 3,229
Kudos: 146
Solutions: 26
Registered: ‎03-20-2011
My Device: iPhone 5
Re: Activating Microcell w/ Comcast home internet
[ Edited ]

Woodister wrote:
In the modem config page it says fragmentation is enabled, but there is no setting to disable it.

Block Fragmented Packets must be disabled. It is a rquirement for the MicroCell and is listed in the Troubleshooting Guide. You'll need to discuss this with Comcast.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Mentor
tim horton
Posts: 68
Registered: ‎01-13-2005
Re: Activating Microcell w/ Comcast home internet

Woodister wrote:
I read on some other forums that comcast's network is screwy and the IP address you get defines if your microcell is going to work. So I renewed my IP address until I got one in the 70.xx.xx.xx range and it worked. Weird.

I have Comcast and my Microcell is working as solid as can be for many many months now. I check my IP address and it is 69.XX.XX.XX.

Otto Pylot
Posts: 3,229
Kudos: 146
Solutions: 26
Registered: ‎03-20-2011
My Device: iPhone 5
Re: Activating Microcell w/ Comcast home internet

Hmmm, it seems that some of Comcast's address tables are more reliable than others. Very odd. At least yours is working fine.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Contributor
paulmc1840
Posts: 1
Registered: ‎09-26-2013
Re: Activating Microcell w/ Comcast home internet

You created an extremely valuable document!  Thank you for sharing it with the community --  hopefully it will help many of us get our microcells working.

Otto Pylot
Posts: 3,229
Kudos: 146
Solutions: 26
Registered: ‎03-20-2011
My Device: iPhone 5
Re: Activating Microcell w/ Comcast home internet

Thank you. It's a community effort so any new information will be added as it becomes available, and verifiable.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Contributor
zeninguem
Posts: 1
Registered: ‎12-21-2013
Re: Activating Microcell w/ Comcast home internet

For the benefit of others...

 

I spent a lot of time trying to get my microcell working and couldn't get any help whatsoever (tried Comcast, AT&T, Cisco and the vendors of the actual Gateways I was dealing with). So I'm hoping this saves someone else time.

 

Some background: I had the "priority connection" working for months home. This is not so great because if you want to have other devices (such as a camera) accessible from outside your network, you can't. But the real reason I had to move away from this was Comcast itself... I got a new Comcast gateway (Technicolor TC8305C) when I upgraded my account; the gateway is a modem/wireless router combo. I first had Comcast "downgrade" my Gateway into only a modem (called running in Bridged Mode). Then I setup priority connection again and things were fine for ... about a week. The mCell then couldn't connect any longer to the Internet. I called and Comcast couldn't get it to work (a computer connected directly to the modem would connect fine to the Internet though...). I already wanted (for other reasons) to not have the MCell in Priority Connection, so I decided to take on Comcast!

 

I went to the Comcast store and picked up all three of their Gateways. I was first successfully getting  the Arris TG862 working, but that Gateway is buggy and once I added two static IP's, I could no longer go to the "connected devices" page, which is where one adds more static IPs. Given that I have quite a few other access points in my house, this was useless. I then reverted to the Technicolor and tried the same there... and it worked. Here's what I know:

 

1. Start fresh (revert your Gateway to "factory settings")

 

2. Boot up the router, connect to it and DO NOT CHANGE ANYTHING (such as intranet IP address range, etc.)

 

3. From the bottom of the MCell, get the MAC address.

 

4. Give your router a range for static IP's (i.e. configure it so that DHCP starts at, say, 10.0.0.20)

 

5. Create a static IP for the MCell using the MAC address from (3)

 

6. Put the static IP of the MCell in the DMZ

 

7. This is speculative, but just in case, turn the Firewall off. You can turn it back on (to highest setting) after all steps.

 

8. Connect the Gateway and plug the power cord (i.e. turn it on)

 

9. The MCell should connect briefly.

 

10. Now, and only now, plug into the Gateway another other ethernet devices you might have (i.e. a main switch)

 

I've also noticed that when I cycle the Gateway or disconnect the cable from the Gateway and reconnect it, I have to power cycle the MCell.

 

Hope this helps. If nothing else, at least know that it is possible to connect an MCell to a Technicolor or Arris gateway provided by Comcast w/o using Priority Connection.

 

Otto Pylot
Posts: 3,229
Kudos: 146
Solutions: 26
Registered: ‎03-20-2011
My Device: iPhone 5
Re: Activating Microcell w/ Comcast home internet

Glad you got it working. A lot of this is covered in the Guide (link in my sig). It doesn't specificially mention the types of modems/gateways but port forwarding is, as well as using a static ip address based on the MicroCell's MAC address. The mandatory basic router configurations are also covered.

 

My gateway is set to Bridged Mode and I let my router (Apple Extreme Base Station) handle all of the traffic. I have it set to port forward the required ports to a static-assigned ip address for the MicroCell. Priority connection is a great way to troubleshoot if your gateway is set to Bridged Mode because it rules out the router which narrows down considerably the possible problems. However, there is nothing wrong with leaving it in Priority Connection if that works best for you.

 

Usually if your connection is fine and there haven't been any changes on your end and there's a sudden loss of connectivity it's more than likely something your ISP has done. In situations like this I always recommend folks to check the obvious things first like loose cables, the cat chewed on a cable, the ac adapter is getting hot to the touch, things like that.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.