Reply
Posted Jan 28, 2014
7:25:19 AM
AT&T SMTP now enforcing "From" email address

I posted earlier about not being able to send email via SMTP and have now figured out the problem. Starting within the last day or so, they are now checking to see that the "From" address on outgoing email matches your AT&T email address and, if not, are rejecting it. This is probably an anti-spam measure, but can cause problems.

 

This is a problem for me since I have my own domain so that I can publicly use an address such as "me@mydomain.com" and have it forward to "me@att.net". The advantage is that I can switch ISPs (which I have done a couple times) without having to change my email address in dozens of places around the web, notify contacts, etc. Email addresses are often used as account logins these days, so changing it is a huge honking deal!

 

I could still use "me @mydomain.com" as the "Reply-to" address, but this can confuse people since they will still see both this and my att.net address and probably not know which is which. So I am going to have to use a different SMTP server to send from my AT&T account in my client email program, which is doable but a hassle.

 

For what it's worth, Gmail's SMTP servers also do not like this, but they will actually change the From address to match the account used to log onto the server (the reason why that's not a solution for me either).

AT&T SMTP now enforcing "From" email address

2,375 views
27 replies
(4) Me too
(4) Me too
Post reply
Replies
(27)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 10:19:17 AM
0
(0)
Employee
Was not aware, thanks for posting findings.
*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: AT&T SMTP now enforcing "From" email address

2 of 28 (2,333 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 1:41:52 PM
0
(0)
Teacher

"Starting within the last day or so, they are now checking to see that the "From" address on outgoing email matches your AT&T email address and, if not, are rejecting it. This is probably an anti-spam measure, but can cause problems."

 

I really appreciate this post, but I have to say this "can cause problems" is an understatment.

 

If this is true as of this moment I'm paying for an ISP to:

 

-Force me to use their outgoing SMTP servers when using an email client because they don't want to be responsible for SPAM

-Have me go through a convoluted setup through Yahoo setup so I can use my business domain instead of att.net because they've outsourced to Yahoo, who themselves apparently can barely handle it.

-And then shut everything but att.net with no notice because it's all too difficult.

 

Time Warner starting to sound really good right now and I'm well out of "special" customer rates. As of this moment, I'm litterally unable to email out of my client because I have no use nor have any plans to go to att.net emails.

 

Honestly, I'm really hoping this isn't true and there's a hiccup with the server. Otherwise there's much pain in my future and U-Verse possibly just lost a client.

Re: AT&T SMTP now enforcing "From" email address

3 of 28 (2,287 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 2:39:10 PM
0
(0)
Tutor

I am the exact same boat and am certainly an unhappy camper.

 

I attemped but was unable to send an email even though I populated the Reply To box w/ my ATT email address.  Did I misunderstand what the workaround is?

Re: AT&T SMTP now enforcing "From" email address

4 of 28 (2,274 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 2:52:22 PM
0
(0)
Tutor
Edited by glr on Jan 28, 2014 at 3:07:50 PM

I think I misunderstood...you are suggesting that I add my desired email address to the Reply To parameter.  But the email has to be sent from my ATT.net email address.  Yes - that is ackward and confusing to the recipient.

 

Like you, I am desperately trying to avoid tying my commonly recognized email address to a specific internet provider but I do not know what my alternatives are.

Re: AT&T SMTP now enforcing "From" email address

[ Edited ]
5 of 28 (2,270 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 3:40:26 PM
0
(0)
ACE - Master

If you want to use a From address that doesn't use the ATT.NET domain, then submit your e-mail to that domain's SMTP server.

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: AT&T SMTP now enforcing "From" email address

6 of 28 (2,254 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 3:51:47 PM
0
(0)
Teacher

glr - I haven't had time to investigate or contact anyone at ATT support. This could be a server outage.(Although I have had 10 minutes to look at other ISP options at this point.).

 

If the above post is true, one option that I've read about but haven't tried is calling and asking for the automatic block on Port 25 to be removed. Once that happens you can use your own SMTP servers, usually supplied with the Internet hosting package that also supports the email.

 

I want to use a local email client and the domain names I've paid for. Sending from my ATT email (used only as a userid for ATT) is just not an option.

 

You'd think the company that was instrumental in the development of the Internet could handle outgoing email. Other ISPs can and do. This is extremely frustrating.

Re: AT&T SMTP now enforcing "From" email address

7 of 28 (2,250 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 3:54:54 PM
0
(0)
Teacher

You can't *get* to most other SMTP servers when your logged on ATT's network. They block Port 25 automatically. That's why this situation stinks. Other ISPs monitor Port 25 rather than just throw their hands up in air and make you deal with it.

 

When I'm on the road, I always switch over to my host's SMTP servers. It always works - I don't "submit" the name, just authenticate my user id.

Re: AT&T SMTP now enforcing "From" email address

8 of 28 (2,251 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 4:03:34 PM
0
(0)
Mentor

I've switched to the SMTP server at my web hosting company that hosts my domains (1&1 Internet). It's a secure SMTP connection that uses port 587 -- not 25. Sending on port 25 is probably a classic way that spam gets sent, whereas my port 587 connection requires a username and password.

 

This is working now, but introduces another potential problem. This particular web host has been known to be used by spammers, so once in a while I can run into a situation where certain big ISPs just start rejecting all email sent from 1&1's IP addresses. That's why I preferred using AT&T's servers, but apparently I now can't win for losing!

Re: AT&T SMTP now enforcing "From" email address

9 of 28 (2,246 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 4:42:26 PM
0
(0)
Tutor

Rochrunner...I am interested in your current solution.  1&1 hosts my site.  Can you give me a highlevel idea of what I need to do to implement the workaround.

Re: AT&T SMTP now enforcing "From" email address

10 of 28 (2,236 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 4:44:55 PM
0
(0)
Teacher

I'll look into Port 587, that may help if ATT is not doing an automtic block. Thanks for the tip.  For the record, using Port 25 also required a userid and password at my hosting company. It was never open. In the end, there's nothing magical about any particular port number. Port 25 is/was indeed the customary SMTP port but once Port 587 becomes "customary", we're back to where we started.

Re: AT&T SMTP now enforcing "From" email address

11 of 28 (2,235 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 4:45:30 PM
0
(0)
Tutor

An interesting observation...I can successfully send emails from my HP Touchpad (webos) even though Outlook2013 on Win7 can not.

Re: AT&T SMTP now enforcing "From" email address

12 of 28 (2,232 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 4:56:30 PM
0
(0)
Contributor
Same problem here. Had this issue when 1st signing up for U-verse last year. Several phone calls and much time involved with a thoughtful U-verse rep finally fixed it. However, we knew something changed over the weekend as outgoing stopped working Sunday night. Regardless of it's nature(port blocking, etc), if I don't find a solution this week, I'll be forced to drop U-verse altogether as I can't send email.

Re: AT&T SMTP now enforcing "From" email address

13 of 28 (2,230 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 5:09:12 PM
0
(0)
Teacher

Success! I looked into the email settings at my own hosting company, which is Hostgator. In CPanel, I accessed the email I use and then selected "Configure Email". It gave me settings for Outgoing SSL, which used Port 465. I also had to use the name of an SMTP server that was specific to my account and Hostgator, which I won't bother with posting because it won't help most people. I have to authenicate outgoing email, but had to do that anyway.

 

So the more generic solution is to check with your hosting company and see if they offer an SMTP server using a port other than 25 if you don't want to wrestle with ATT support.

 

I have to admit I'm still adding looking for an another ISP to the "to do" list. It's only a matter of time before 587 (and 465) become overrun unless there's an upgrade to the technology I don't know about. (Totally possible given that I'm in a different field now. :smileyhappy: ) At any rate, the automatic block on 25 was never the way to solve the issue nor was turning off everything but ATT.net and letting us mere customers find out about it by letting it break.

Re: AT&T SMTP now enforcing "From" email address

14 of 28 (2,224 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 5:12:55 PM
0
(0)
Teacher

@rochrunner- Thanks for the tip - it led to my returning to sucessful outbound email. My solution at my hosting company is basically the same but with a different port number. Good luck! :smileyhappy:

Re: AT&T SMTP now enforcing "From" email address

15 of 28 (2,221 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 6:08:38 PM
0
(0)
Tutor
Edited by Phil-101 on Jan 28, 2014 at 7:42:02 PM

rochrunner, thanks to you, I can now send emails through 1&1 using an email account associated with my website....thanks

 

I still need to be able to send email from my personal ***@Outlook.com account...am I doomed?

 

[edited for privacy]

Re: AT&T SMTP now enforcing "From" email address

[ Edited ]
16 of 28 (2,210 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 7:12:08 PM
0
(0)
Tutor

That's not really an option when AT&T also blocks port 25 - which is what many of the other ISPs use

Re: AT&T SMTP now enforcing "From" email address

17 of 28 (2,197 Views)
0
(0)
  • Rate this reply
View profile
Jan 28, 2014 7:51:36 PM
0
(0)
ACE - Master

glr wrote:

rochrunner, thanks to you, I can now send emails through 1&1 using an email account associated with my website....thanks

 

I still need to be able to send email from my personal ***@Outlook.com account...am I doomed?

 

[edited for privacy]


You can use Outlook.com's own SMTP servers, they can use port 587 if 25 is blocked.

 

See http://windows.microsoft.com/en-us/windows/outlook/send-receive-from-app

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: AT&T SMTP now enforcing "From" email address

18 of 28 (2,188 Views)
0
(0)
  • Rate this reply
View profile
Jan 29, 2014 5:48:52 PM
0
(0)
Tutor

Outbound is suddenly working fine...

Re: AT&T SMTP now enforcing "From" email address

19 of 28 (2,108 Views)
0
(0)
  • Rate this reply
View profile
Jan 30, 2014 10:54:12 AM
0
(0)
Tutor

After spending two hours with support and getting nowhere, I decided to call it a night and talk with a specialist the next morning.  Somehow, during the night, my Thunderbird started working again as well.  But no, the problem wasn't anything that got changed on their end. :smileyfrustrated:

Re: AT&T SMTP now enforcing "From" email address

20 of 28 (2,070 Views)
0
(0)
  • Rate this reply
View profile
Jan 30, 2014 2:09:17 PM
0
(0)
ACE - Master

Someone may have misconfigured something that they weren't supposed to put their fingers in.

 

Apparently, there is no such policy shift to require an ATT.NET from address to send via ATT.NET SMTP servers at this time.  

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: AT&T SMTP now enforcing "From" email address

21 of 28 (2,055 Views)
0
(0)
  • Rate this reply
View profile
Feb 5, 2014 12:36:46 PM
0
(0)
Mentor

Well its a week and counting for me and still the crack tech staff at AT&T can't figure out why their email server now sometimes rejects my outbound emails sent from my email client Agent.

 

Two clues:

 

1. They (AT&T) admit they didn't set up my AT&T email correctly on their end.

2. Agent clearly shows it makes a connection and reports "connection refused".

 

You don't have to be a technical guru to figure out something is obviously wrong on AT&T end.

 

Lets see what we can find out. Agent also shows the IP address it is trying to connect to which is 98.139.211.230. OK, lets do a whois lookup for this IP.

 

Results:

 

OrgName: Yahoo! Inc.
OrgId: YHOO
Address: 701 First Ave
City: Sunnyvale
StateProv: CA

 

So in spite of being told to enter outbound.att.net as the email server to connect with the IP address resolves to a Yahoo location. So...

 

1. that's the incorrect email server to point to

2. AT&T and/or Yahoo still don't have my correct email address set up.

Re: AT&T SMTP now enforcing "From" email address

22 of 28 (1,950 Views)
0
(0)
  • Rate this reply
View profile
Feb 7, 2014 7:02:15 PM
0
(0)
Tutor

THANK YOU SO MUCH for taking the time to post your solution!!! So many people post their problems, begging for help, but never post anything when they find the solution, leaving the rest of us still begging for help. U-Verse was just installed in my house and I thought it was great, really excited, loved the internet speed and HD quality, much better than the best Brighthouse services... until I realized my entire days "sent" emails were stuck in the outbox on whatever device they were sent from. Not good. U-Verse was about to get a very angry phone call because I could not send outgoing mail via Outlook or any other email program from my business email domain through GoDaddy on the computer, laptop, or smartphones that were connected to this U-Verse internet modem or via the wi-fi. Email worked fine on the smartphones when disconnected from U-Verse wi-fi, using only Sprint's service. Clearly a U-Verse issue. Big problem, as 90% of my work is internet/email based communication, and clients apparently have not been receiving my emails all day. My email HAS to work 24/7.

 

Customer support, clearly in Uganda or some similar foreign country, barely speaks english beyond reading his cue cards, helped by offering to sign me up for "advanced support" for only an additional 15.00 a month. Wonderful.. thanks.. Probably would have paid that 15.00 a month just to be transferred to  "advanced" support in Nicaragua to be told that I would have to pay for some other service or equipment to get my email to be compatible with U-Verse. I honestly don't understand why these companies that offer "better customer service" with "live support" seem to think that live support from another country is an upgrade from the competitions automated support. I would rather push buttons and deal with the robot that leads to nowhere. Large companies want to hire foreigners for less money than they would pay an American company to handle their customer service, when in reality, they are losing money from fed up, potentially lifetime customers, that can't get a real answer and cancel their services. Could we get live American support that is actually familiar with the products? That would be awesome. Products are great, but really wish the customer service quality would be equivalent to that of the products. Whatever.. until then, I will stick with "Google support".. searching the web is free and always provides a solution. 

 

Anyhow, after the failed attempt of using customer support for a solution, I tried U-Verse help links.. only tells you how to setup their ATT mail on Outlook. No advice for using other domains, which is terrible, as this is apparently a very common problem/complaint with this service. Tried searching Google, found this is a widespread problem that has existed for years with thousands of posted pleas for help and recommendations that failed (including the original post on this thread that I found by searching Google, as they have changed everything in their email in the 5 years since 2009 when posted..). About 5 minutes away from giving up and making an angry phone call back to Uganda to cancel this service, scrolling through the threads following the original post here.. still dreadfully hoping for an answer so I don't have to cancel my new service over such a ridiculous problem.. I finally came upon this post and checked the GoDaddy site. They also support SSL outgoing port 465 as mentioned in the post. I changed all computer/smartphone outgoing server settings to SSL 465, and suddenly the 20 emails I have sent today are going through perfectly from all devices.

 

3 hours of troubleshooting, for a 2 second fix... They should really teach their installers and customer service reps to point that out to new customers. Thank God I am patient and computer literate enough to know how to troubleshoot, research problems, and also know how to manage my own server settings. I can't imagine what those who are less technical have to go through to resolve it. I am sure there are others doing crazy things trying to get their email to work, wasting hours, wasting money on IT help, calling domain providers, messing up all kinds of computer settings, putting their computers through the wall, and causing more problems for themselves. Who even knows what "advanced support" in Nicaragua is telling the people paying for extra service to do to their computers to fix it. AT&T's U-Verse has surely had to lose some business over this one, seemingly large, yet very small technical issue, as I almost joined them had I not became so angry with the customer service and taken the time to try and figure it out for myself. AT&T U-Verse should give you a free year of service for doing their job and keeping their business from losing their customers that were lucky enough to stumble across your post on their site. Your advice will probably save a lot of business for them. I know it just saved one new customer from cancelling..  You are awesome. Thank you, thank you, thank you!! 

Re: AT&T SMTP now enforcing "From" email address

23 of 28 (1,902 Views)
0
(0)
  • Rate this reply
View profile
Feb 7, 2014 7:17:56 PM
0
(0)
Tutor

What worked for me, was to use the advice someone posted earlier. If you are using Outlook or some other email program, set your outgoing server in Outlook or whatever program or app you are running your email through, to SSL, then change outgoing Port 25 to say Port 465 and save the changes. I can now send email from my GoDaddy mail server through outlook and my android phone while connected to AT&T U-Verse internet and wi-fi. Hope your problem is the same issue I was having, and that simple solution helps you.

Re: AT&T SMTP now enforcing "From" email address

24 of 28 (1,896 Views)
0
(0)
  • Rate this reply
View profile
Feb 7, 2014 8:12:26 PM
0
(0)
ACE - Master

Why on earth would you expect AT&T to tell you how to setup e-mail to someone else's e-mail server?

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: AT&T SMTP now enforcing "From" email address

25 of 28 (1,890 Views)
0
(0)
  • Rate this reply
View profile
May 16, 2014 11:37:21 AM
0
(0)
Contributor
5-16-2014 and the fingers are still there. After the "new" ATT mail was automatically installed on my sbcglobal.net account, my outgoing mail usually but not always is defaulted to the canoelac2@yahoo.net that I dont want to use. No answers in the community that I can find.

Re: AT&T SMTP now enforcing "From" email address

26 of 28 (1,194 Views)
0
(0)
  • Rate this reply
View profile
May 16, 2014 11:39:26 AM
0
(0)
Contributor

Why is ATT forcing me to use a return address that is NOT my primary sbcglobal.net address???

Re: AT&T SMTP now enforcing "From" email address

27 of 28 (1,194 Views)
0
(0)
  • Rate this reply
View profile
May 16, 2014 12:17:53 PM
0
(0)
ACE - Master
canoelac - If you are using SMTP you are using an app such as outlook or macmail, there are a number of opportunities to select what address is used.

Check out you computer default.
Check out how your list of options to apply when sending is presented
When actually sending be sure you have the one you want.
There could be an option to use the original one on replies.

It is great to manage multiple mail accounts with these apps, but it is possible to apply the wrong account when sending an e-mail. Ask me how I know.
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: AT&T SMTP now enforcing "From" email address

28 of 28 (1,187 Views)
Share this post
Share this post