Reply
Posted Feb 11, 2013
3:50:45 PM
View profile
Using Third party VOIP service with ATT-Uverse internet: Call Drops after some time

I swtiched from comcast to ATT Uverse and now the call drop after 5-6 minutes. For first five minutes, there is no issue with the call.  I am using SIPURA SPA 2102 and PAP2T and my voip provider is future9.com for local calls and voipdiscount for international calls. I am using pbxes.org to host my device.

I am forwarding the port 5060 and RTP ports (16384 - 16482) to my device IP address 192.168.1.101. The device is set to DHCP but I am using the router to reserve this address. 

Can you help? Do I need to change some settings in the Residential Gateway provided by ATT?

I saw in pbxes.org system log:
NOTICE[8998] chan_sip.c: Disconnecting call 'SIP/tjsingh-201-cded' for lack of RTP activity in 61 seconds

Not sure if this message is useful.

0
(0)
  • Rate this reply
View profile
Solved
Feb 13, 2013 3:51:30 AM
0
(0)
ACE - Expert

I located this about port 5060:

 

"The U-Verse service requires the customer to use a router that was designed specifically for U-Verse Internet, TV, and phone service.  This router has a default setting called SIP-ALG that cannot be disabled and the router cannot be replaced while using U-Verse internet.  SIP-ALG is a router function that will cause VoIP traffic to be rewritten, which can cause problems such as one way audio, dropped calls, and inbound and outbound call failure.  If you are familiar with making changes to your voice over IP phone/device, you will want to modify the source port of the phone to a port other than 5060 and reboot the U-Verse router."

"If you find this post helpful and it solved your issue please mark it as a solution.  This will help other forum members locate it and will also let everyone know that it corrected your problem. If they have the same issue they will know how to solve theirs"

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Accepted Solution

Using Third party VOIP service with ATT-Uverse internet: Call Drops after some time

6,940 views
7 replies
(0) Me too
(0) Me too
Post reply
Replies
(7)
0
(0)
  • Rate this reply
View profile
Feb 11, 2013 5:07:12 PM
0
(0)
ACE - Expert

My suggestion would be to call your providers future9.com and voipdiscount to see if they can offer assistance.  Maybe they can pull up some log files to pin point why they are disconnecting you after 5 minutes.  To me internet is internet.  Your service from AT&T doesn't know your on a phone call and disconnect you after 5 minutes.  Maybe another entinty that monitors internet traffic might, but not AT&T.

"If you find this post helpful and it solved your issue please mark it as a solution.  This will help other forum members locate it and will also let everyone know that it corrected your problem. If they have the same issue they will know how to solve theirs"

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Using Third party VOIP service with ATT-Uverse internet: Call Drops after some time

2 of 8 (6,927 Views)
0
(0)
  • Rate this reply
View profile
Feb 12, 2013 3:30:57 AM
0
(0)
Tutor

I had also posted my question here:

 

http://www2.pbxes.com/forum/thread.php?threadid=1360037146&sid=34eea56de44913ce2d0ff0ceebcda4cc


After resetting the SPA 2102 and PAP2T, problem was still there. I stumbled upon this post:

http://www.toao.net/25-linksys-ata-configuration

and the only change I made after the factory reset was 
>>As we planned to place our device behind a router, we turned on NAT Mapping and NAT Keep Alive.

(I also changed SIP T1 to 1 and Reg Retry Long Intvl to 120. but I don't think it is related to dropped calls.)

I didn't mess with other NAT support parameters yet, which are No by default.. I have come across posts which talk about setting some of these parameters to Yes when NAT Mapping is enabled.

NAT Support Parameters
Handle VIA received: Handle VIA rport: 
Insert VIA received: Insert VIA rport: 
Substitute VIA Addr: Send Resp To Src Port: 
STUN Enable: STUN Test Enable: 

I was able to make outgoing local call (which uses future9 voip) that did not drop even after 15 minutes. Earlier it used to drop after 9-10 minutes. I will keep my finger crossed and see if it holds for incoming (future9 voip) and international calls (voipdiscount voip)

I also found that Future 9 also recommended NAT Mapping Enable:
http://www.future-nine.com/faq/content/1...spa-device.html

You were right about taking the issue with the VOIP provider.


Thanks for your support.

Regards.

Re: Using Third party VOIP service with ATT-Uverse internet: Call Drops after some time

3 of 8 (6,885 Views)
0
(0)
  • Rate this reply
View profile
Feb 13, 2013 12:12:39 AM
0
(0)
Tutor

I made two outgoing US calls that dropped after 15 minutes and 29 minutes respectively. The battle is far from over. Need to find a way to debug this. Will contact future9 to see if they can help. PBX status log shows:

NOTICE[87791] chan_sip.c: Disconnecting call 'SIP/tjsingh-201-d87b' for lack of RTP activity in 61 seconds

 

Any clues, folks?

Re: Using Third party VOIP service with ATT-Uverse internet: Call Drops after some time

4 of 8 (6,820 Views)
0
(0)
  • Rate this reply
View profile
Solved
Feb 13, 2013 3:51:30 AM
0
(0)
ACE - Expert

I located this about port 5060:

 

"The U-Verse service requires the customer to use a router that was designed specifically for U-Verse Internet, TV, and phone service.  This router has a default setting called SIP-ALG that cannot be disabled and the router cannot be replaced while using U-Verse internet.  SIP-ALG is a router function that will cause VoIP traffic to be rewritten, which can cause problems such as one way audio, dropped calls, and inbound and outbound call failure.  If you are familiar with making changes to your voice over IP phone/device, you will want to modify the source port of the phone to a port other than 5060 and reboot the U-Verse router."

"If you find this post helpful and it solved your issue please mark it as a solution.  This will help other forum members locate it and will also let everyone know that it corrected your problem. If they have the same issue they will know how to solve theirs"

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Using Third party VOIP service with ATT-Uverse internet: Call Drops after some time

5 of 8 (6,814 Views)
Solution
0
(0)
  • Rate this reply
View profile
Feb 14, 2013 1:33:28 AM
0
(0)
Tutor

Thanks BeeBee.

   That was a nice find. I have changed the SIP port number. I will update in couple of days if it made any difference.

 

Future9 support had following to say. They are willing to put a trace if problem continues.

 

Hello,

Basically it comes down to internet connectivity - either you->pbxes or
pbxes->us had a momentary loss of internet service. Or otherwise another
issue with pbxes - I'm not aware of any issues on our side around the
time
of those calls.

This specific issue wouldn't be caused by settings so no need to tweak
anything. Only thing you can do to get it more stable is stop using
pbxes
and connect to us directly, but I understand if that's not desirable for
you.

Thanks! 

Re: Using Third party VOIP service with ATT-Uverse internet: Call Drops after some time

6 of 8 (6,764 Views)
0
(0)
  • Rate this reply
View profile
Feb 14, 2013 5:44:36 AM
0
(0)
ACE - Expert

Good deal.  Look forward to hearing back to see if that corrected the issue so we will know if it ever comes up again with someone else.

"If you find this post helpful and it solved your issue please mark it as a solution.  This will help other forum members locate it and will also let everyone know that it corrected your problem. If they have the same issue they will know how to solve theirs"

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Using Third party VOIP service with ATT-Uverse internet: Call Drops after some time

7 of 8 (6,752 Views)
0
(0)
  • Rate this reply
View profile
Apr 1, 2013 11:17:33 AM
0
(0)
Tutor

I was using two PlugLink 9650 ethernet adapters (they plug to power outlets and have ethernet port) to provide internet connection to my Cisco SPA 3102. My residential gateway was in one room and ATAs in different room. AT&T technician pointed out that I would be getting only 1.5Mbps speed from these adapters while my residential gateway is giving 12Mpbs. I was able to install a repeater bridge (flashing dd-wrt to wrt54g) to provide close to 8Mpbs to the ATAs. I am not seeing the call drop after this.

Re: Using Third party VOIP service with ATT-Uverse internet: Call Drops after some time

8 of 8 (6,051 Views)
Share this post
Share this post