Reply
Posted Oct 4, 2011
NVG510 Bridge Mode???

Just switched from DSL (Motorola 2210) to UVerse (Motorola NVG510). I set the 2210 into bridge mode and ran my home network from an Apple Airport Extreme Base Station (AEBS). I have some complex configurations on my network and figured I'd be able to do the same thing with the NVG510. However, it seems the NVG510 uses different terminology than I am used to.

 

Under Firewall/IP Passthrough, I set:

Allocation Mode to 'Passthrough'

Passthrough Mode to 'DHCPS-Fixed'

Passthrough Fixed MAC Address to the AEBS' MAC address

And, I left the Lease at the default 10 minutes.

 

On the AEBS, under Internet/Internet Connection, I switched from 'PPPoE' to 'Ethernet'. I left the Ethernet WAN Port value at 'Automatic (Default)'. And Connection Sharing is set to 'Share a public IP address'.

 

This apparently is not enough, though. The AEBS reports that the "Wi-Fi base station does not have a valid IP address", and that there is a "Conflicting DHCP Range".

 

How do I turn off the DHCP on the NVG510? And, what are the correct settings to put the NVG510 into bridged mode?

0
(0)
  • Rate this reply
Solved
10-22-2011 10:25:15 AM
0
(0)

A long post, but hopefully worth the reading:

 

I had some weird things happening the weekend after I set up my NVG510 as described above in the post starting:

"Okay, so here's what I've done that seems to be working at the moment...

 

- In the NVG510's setup, under Home Network, then Subnets & DHCP, I set the following:"

 

The Issue:

When family members were trying to access the Internet with multiple devices, things kept locking up. Say for example, the kids were trying to watch videos, one on an iPad, the other on an iPod Touch. The videos were buffering really slowly and kept locking up. So... back to the drawing board. Now, I have some interesting findings and a new setup.

 

The Research:

I researched IP-DSL and IP Passthrough a bit. It seems that IP-DSL, which U-verse is using, is actually using IP like a typical ethernet network. (Their prior DSL used ATM, which is a bit more complex technology.) The U-verse Residential Gateway (RG) is getting an IP address and gateway just like anything else you set up with IP and DHCP. The "Broadband IPv4 Address" on the Broadband Status tab is the public IP handed out to the RG. The "Gateway IPv4 Address" is the AT&T router managing the RG (typically called the "Default Gateway").

 

IP Passthrough is supposed to allow another device to receive the IP address of the RG. When IP Passthrough is turned on, then, the NVG510 is supposed to give its own public IP address to a specified LAN device. The instructions on the right-hand side of the IP Passthrough tab confirm this.

 

The Theoretical Setup

To set up the NVG510 correctly, then, for use with a home router (assuming you don't want to simply let your home router be a bridge, of course) -

 

Starting with the NVG510's default settings:

 

- Under Home Network, then Subnets & DHCP, I set the following:

Device IPv4 Address: <the IP address I want to use for the RG (the default is 192.168.1.254, which is okay too)>

DHCPv4 Start Address: <some IP address within the RG's subnet (say 192.168.1.1)>

DHCPv4 End Address:  <the same IP address as the Start Address, above (since I'm not using the NVG510's DHCP)>

 

- Under Home Network, Wireless,

Wireless Operation: Off

 

- Under Firewall, IP Passthrough,

Allocation Mode: Passthrough

Passthrough Mode: DHCPS-fixed

Passthrough Fixed MAC Address: <MAC address of the home router>

 

On the AEBS, then:

 

- Under Internet, Internet Connection,

Connect Using: Ethernet

Connection Sharing: Share a Public IP Address

 

- Under Internet, TCP/IP,

Configure IPv4: DHCP

 

- Under Internet, DHCP, the DHCP values are set as normal, with an address range in a different subnet from the RG, though, in order to prevent double NAT messages. (For example, if the RG is 192.168.1.x, the AEBS is 192.168.2.x)

 

Restart the NVG510, then the AEBS.

 

Theoretically, the NVG510 should, using its own DHCP, give the AEBS its own public IP address (the "Broadband IPv4 Address"), a valid Subnet Mask, and the Default Gateway (Router) value equal to the "Gateway IPv4 Address".

 

In actuality, for some reason, the NVG510 only will give the AEBS its Gateway  and DNS values. The AEBS gets an internal IP address and a Subnet Mask of 255.255.255.255. I suspect a bug, er, "feature", in the NVG510's firmware...

 

The Actual Setup

The fix, then, is to set everything up as described above - except... in the AEBS, I changed the last step:

 

- Under Internet, TCP/IP,

Configure IPv4: Manually

IP Address: <the RG's "Broadband IPv4 Address">

Subnet Mask: 255.255.0.0 (Note that I'm not certain this is correct. The NVG510 doesn't show a subnet mask on its Broadband/Status tab, but the values I have showing would work with this mask.)

Router: <the RG's "Gateway IPv4 Address">

DNS: <the RG's "local" IP address (e.g., 192.168.1.254 by default)>

 

Yay, It Works

No more lockups; everything is running smoothly with multiple devices accessing the Internet at the same time.

 

I'm going to mark this post as the answer, though hopefully I won't later get my hand slapped and told how I terribly messed things up - i.e., anybody trying anything I suggest in any post anywhere does so at their own risk, of course. I don't claim to be an expert - just yet another experimenter in the 'net world. Anybody with more expertise and good explanations is welcome to jump in!

Accepted Solution

NVG510 Bridge Mode???

126,305 views
86 replies
(0) Me too
(0) Me too
Post reply
Replies
(86)
0
(0)
  • Rate this reply
Oct 4, 2011
0
(0)

Amen--twice...I've spent the last four hours trying to get the NVG510 to play nice but it refuses. All my port forwarding and assigned DHCP numbers are in my AEBS and I'd like to keep it that way. How can it be so hard to make this thing a Bridge? I don't need the firewall or any of that other mess. I need the data stream, end of discussion.

 

If anyone has step by step instructions, I'm begging you to post them.

 

I called "tech support" and was told they'd be happy to tell me how to do that for $15 a month. Yes, a month. No, I'm not kidding. They put this in the category of "supporting 3rd party hardware". Every day I'm more apalled by how AT&T treats their customers. Well, when they're the only game in town, really, you're sort of their prisoner. And now that I think about it, that's how they treat me. 

 

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Oct 5, 2011
0
(0)

Yes - and notice the wording of my specific questions:

 

How do I turn off DHCP on the NVG510?

 

How do I turn on Bridge Mode on the NVG510?

 

This has nothing to do with 3rd-party device support. I am NOT asking what to set on my AEBS, actually. I AM asking how to do these two things on the NVG510. I can worry about my own settings behind the NVG510 after that. I listed my AEBS settings for clarification, in case it might help. This question is NOT about 3rd-party device support.

 

(Please, please, please let T-Mobile (with excellent customer service) NOT be sucked up by AT&T...)

Re: NVG510 Bridge Mode???

[ Edited ]
0
(0)
  • Rate this reply
Oct 5, 2011
0
(0)

I'm glad I'm not the only one having this issue.

 

I've tried every setting that is avaialble. Hopefully a firmware update can "fix" the inability to turn off the DHCP server or be able to set it to bridge mode.

 

My 7 year old Speedstream 5100 is looking a lot better as far as being a dumb device that did exactly what I needed it to do. Too bad it doesn't work with U-Verse DSL

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Oct 5, 2011
0
(0)

I suspect quite a few people are haing this problem, not just the three of us..

 

And yes, lisfolks, I agree--the questions are about THEIR router, not OUR equipment. It infuriates me, but what can you do? I'm picking the brain of every network person I can find to see if there is a solution out there. So far I've come up empty, but I promise to post anything I find out. 

 

I tried using the router in the NVG510 this morning, but its garbage. You can only indicate the computer you want to port forward to if you use the presets. If you use a custom port (as I often do for things like SSH so they are not easily found), you cannot indicate the machine to forward the port to. 

 

And yes, ktalley, my old DSL modem is looking good to me, too. If I can't sort this out and make it workable by Monday, it's going back to AT&T and they can cancel this Uverse account and put me back on DSL. At least it worked the way I needed it to. 

Re: NVG510 Bridge Mode???

[ Edited ]
0
(0)
  • Rate this reply
Oct 5, 2011
0
(0)

I use fixed IP addresses on some of my devices (via DHCP), but you can't do that with the NVG510. Also, I use both bands on my AEBS to avoid interference on the 2GHz band for those devices that can utilize the higher 5GHz band. The NVG510 can't do that, either. The AEBS also allows me to connect a printer and an external disk drive that I otherwise couldn't put on the network without dedicating a PC for sharing - of course, the NVG510 can't do that, either.

 

I would've stayed with the DSL, but my apartment complex has been wired for UVerse now. When I moved into another apartment in the same complex, AT&T said that I had been grandfathered to the DSL, but now HAD to switch to the UVerse internet in the new apartment. I WILL switch to the first alternative that comes 'round if AT&T stays on its current course. This is the first time a move has gone well for me with AT&T - but I did this one through AllConnect, rather than directly through AT&T.

 

In the meantime, yes, if I find some way to bridge this, I will be posting it! Crossing my fingers and moving forward....

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Oct 5, 2011
0
(0)

Well, just talked to Motorola's tech support. They said that neither the NVG510 nor the 2210 (with the 1ATT suffix on the model name) are bridgeable. They said those are the only two gateways they make that are not bridgeable, and it appears that is by AT&T's specification.

 

So, anybody know a good DSL alternative for AT&T? I can't do Charter in my complex. (Their customer service should be up and coming - T-Mobile's customer service managers decided to head over there to see what they can do. Started back in January, and have a couple of pilots going for proof-of-concept.)

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Oct 5, 2011
0
(0)

Doesn't that just figure. I've just wasted two hours of my life I won't get back trying to get this thing configured and its all for nothing...oh well, Uverse can say goodby to me. 

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Oct 5, 2011
0
(0)

Well, it seems the tech support people lied not once but twice. First they insisted for two hours I could bridge the NVG510. Then they told me I could switch to the Motorola 2210 and bridge that. Glad I read this first before I dove into another wasted week of trying to get AT&T Uverse to work. I'm so tired of being treated like I'm a burden on these people--I'm paying for a service I'm not getting and they act like I'M the problem...

 

Thanks for the information, I really appreciate it. 

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Oct 5, 2011
0
(0)

I'm still hoping for a way to do it - at least for a little while longer. I'll post if I find anything. (That's just 'cause I'm stuck with them for the time being. Looking into Clear at this point, though I've seen bad reviews on their service - not as bad as AT&T, though, so far <grin>....)

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Oct 6, 2011
0
(0)

Okay, so here's what I've done that seems to be working at the moment...

 

- In the NVG510's setup, under Home Network, then Subnets & DHCP, I set the following:

Device IPv4 Address: an IP address that is within the same subnet as my AEBS

DHCPv4 Start Address and DHCPv4 End Address: the IP address I use for the AEBS.

 

(This means the NVG510 won't be trying to give out IP addresses to anything else, even though the DHCP is still on.)

 

- Under Home Network, then Wireless, I set Wireless Operation: Off.

 

- Everything else in the NVG510 is set to the defaults.

 

- On the AEBS, under Internet, then Internet Connection, I set the following:

Connect Using: Ethernet

Connection Sharing: Distribute a range of IP addresses

 

(On the AEBS, this turns off the NAT while leaving the DHCP active. I just left my IP address range at what I originally had in place.)

 

- Under Internet, then TCP/IP, I set Configure IPv4: Manually

then I entered the appropriate information matching the IP address I set in the NVG510's DHCPv4 Start and End Address fields.

 

- Then, I restarted both devices.

 

Now, the NVG510's device list is showing all of the devices on my network as 'static' (meaning they have manually set IP addresses). The only one that's actually static, of course, is the one I set for the AEBS. The rest are being provided BY the AEBS' DHCP.

 

This works for my needs for the time being. It allows me to use both my Wi-Fi bands, keep my existing IP structure, including fixed IPs provided by DHCP in the AEBS, and use the printer and disk I have connected to the AEBS as normal. And, the network speed doesn't seem to have been affected in any strange way so far.

 

We don't do any gaming or port forwarding - that will be for someone else to figure out, I guess. Hopefully, this'll help a few people out...

 

 

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Oct 8, 2011
0
(0)

Glad to see your up and running. Thanks for coming back and posting your solution. :smileyhappy:

 

What I can't figure out is why AT&T, when selling internet services only, does not ask if the customer has/uses a third party router and just send them a passive modem instead of a full blown router/access point. That would save a lot of headaches, for their customers and their tech support department.

 

 

 

 

 

 

 

__________________________________________________________
How can you be in two places at once, when your not anywhere at all?
------------------------------------------------------------------------------------------------------
I really want to become a procrastinator, but I keep putting it off.
------------------------------------------------------------------------------------------------------
There are three kinds of people, those that can count, and those that can't.
------------------------------------------------------------------------------------
“Our great democracies still tend to think that a stupid man is more likely to be honest than a clever man, and our politicians take advantage of this prejudice by pretending to be even more stupid than nature has made them.

Bertrand Russell

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: NVG510 Bridge Mode???

[ Edited ]
0
(0)
  • Rate this reply
Oct 15, 2011
0
(0)

In my case I had a 2210-02-1ATT from a previous U-Verse DSL account.

On my new activation, before hooking up the NVG510 I tried first hooking up the 2210, all lights went green, I was greeted by the activation screen then proceeded to activate my new account. The activation was successful.

I just set the DMZ on the Ethernet port of the 2210-02-1ATT . Then set publlic DNSes on my Asus router (4.2.2.1 for example).

Remote Desktop, IIS and FTP work great on my HTPC. So I assume the 2210 is letting all traffic flow to my Asus router.

 

I dont know if this will work for a current account. 

But if you can get your hands on a used cheap 2210-02-ATT it might be worth a shot. In theory the lights should go green and at the most it should be a matter of activating using your current Member ID.

 

Based on all users comments across the web,  looks like the NVG510 is just doodoo.

 

AT&T at least needs to give the customer the option.

Re: NVG510 Bridge Mode???

[ Edited ]
0
(0)
  • Rate this reply
Solved
Oct 22, 2011
0
(0)

A long post, but hopefully worth the reading:

 

I had some weird things happening the weekend after I set up my NVG510 as described above in the post starting:

"Okay, so here's what I've done that seems to be working at the moment...

 

- In the NVG510's setup, under Home Network, then Subnets & DHCP, I set the following:"

 

The Issue:

When family members were trying to access the Internet with multiple devices, things kept locking up. Say for example, the kids were trying to watch videos, one on an iPad, the other on an iPod Touch. The videos were buffering really slowly and kept locking up. So... back to the drawing board. Now, I have some interesting findings and a new setup.

 

The Research:

I researched IP-DSL and IP Passthrough a bit. It seems that IP-DSL, which U-verse is using, is actually using IP like a typical ethernet network. (Their prior DSL used ATM, which is a bit more complex technology.) The U-verse Residential Gateway (RG) is getting an IP address and gateway just like anything else you set up with IP and DHCP. The "Broadband IPv4 Address" on the Broadband Status tab is the public IP handed out to the RG. The "Gateway IPv4 Address" is the AT&T router managing the RG (typically called the "Default Gateway").

 

IP Passthrough is supposed to allow another device to receive the IP address of the RG. When IP Passthrough is turned on, then, the NVG510 is supposed to give its own public IP address to a specified LAN device. The instructions on the right-hand side of the IP Passthrough tab confirm this.

 

The Theoretical Setup

To set up the NVG510 correctly, then, for use with a home router (assuming you don't want to simply let your home router be a bridge, of course) -

 

Starting with the NVG510's default settings:

 

- Under Home Network, then Subnets & DHCP, I set the following:

Device IPv4 Address: <the IP address I want to use for the RG (the default is 192.168.1.254, which is okay too)>

DHCPv4 Start Address: <some IP address within the RG's subnet (say 192.168.1.1)>

DHCPv4 End Address:  <the same IP address as the Start Address, above (since I'm not using the NVG510's DHCP)>

 

- Under Home Network, Wireless,

Wireless Operation: Off

 

- Under Firewall, IP Passthrough,

Allocation Mode: Passthrough

Passthrough Mode: DHCPS-fixed

Passthrough Fixed MAC Address: <MAC address of the home router>

 

On the AEBS, then:

 

- Under Internet, Internet Connection,

Connect Using: Ethernet

Connection Sharing: Share a Public IP Address

 

- Under Internet, TCP/IP,

Configure IPv4: DHCP

 

- Under Internet, DHCP, the DHCP values are set as normal, with an address range in a different subnet from the RG, though, in order to prevent double NAT messages. (For example, if the RG is 192.168.1.x, the AEBS is 192.168.2.x)

 

Restart the NVG510, then the AEBS.

 

Theoretically, the NVG510 should, using its own DHCP, give the AEBS its own public IP address (the "Broadband IPv4 Address"), a valid Subnet Mask, and the Default Gateway (Router) value equal to the "Gateway IPv4 Address".

 

In actuality, for some reason, the NVG510 only will give the AEBS its Gateway  and DNS values. The AEBS gets an internal IP address and a Subnet Mask of 255.255.255.255. I suspect a bug, er, "feature", in the NVG510's firmware...

 

The Actual Setup

The fix, then, is to set everything up as described above - except... in the AEBS, I changed the last step:

 

- Under Internet, TCP/IP,

Configure IPv4: Manually

IP Address: <the RG's "Broadband IPv4 Address">

Subnet Mask: 255.255.0.0 (Note that I'm not certain this is correct. The NVG510 doesn't show a subnet mask on its Broadband/Status tab, but the values I have showing would work with this mask.)

Router: <the RG's "Gateway IPv4 Address">

DNS: <the RG's "local" IP address (e.g., 192.168.1.254 by default)>

 

Yay, It Works

No more lockups; everything is running smoothly with multiple devices accessing the Internet at the same time.

 

I'm going to mark this post as the answer, though hopefully I won't later get my hand slapped and told how I terribly messed things up - i.e., anybody trying anything I suggest in any post anywhere does so at their own risk, of course. I don't claim to be an expert - just yet another experimenter in the 'net world. Anybody with more expertise and good explanations is welcome to jump in!

Re: NVG510 Bridge Mode???

Solution
0
(0)
  • Rate this reply
Oct 30, 2011
0
(0)

Thanks for all your hard work lisfolks. This last configuration setting worked for me.

 

There is one caveat though. Since I don't have a static IP address from AT&T, the RG's Broadband IP address is going to change at some point and the AEBS won't get that updated address automatically. I guess I'll find out what happens when that my current ip-address lease is up.

 

Good work

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Oct 30, 2011
0
(0)

Yes, ktalley, I agree. My regular DSL addresses changed frequently. However, the Broadband and Gateway addresses on the RG have stayed the same, so far (going on a month now). I'm hoping that's a function of the IP-DSL they use. My thought is that the address, even though public, works like it's private - unless they give you a static IP, it won't be reachable directly from the outside. Either way, I'm definitely keeping my eyes open for it to change.

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Nov 6, 2011
0
(0)

lisfolks wrote:

Yes, ktalley, I agree. My regular DSL addresses changed frequently. However, the Broadband and Gateway addresses on the RG have stayed the same, so far (going on a month now). I'm hoping that's a function of the IP-DSL they use. My thought is that the address, even though public, works like it's private - unless they give you a static IP, it won't be reachable directly from the outside. Either way, I'm definitely keeping my eyes open for it to change.


Your IP address should not change unless they change your port assignment or change the main IP address of the equipment up the line due to upgrades.

Thanks for posting your solution.

*I am an AT&T employee and the postings on this site are my own and don’t necessarily represent AT&T’s position, strategies or opinions.

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Nov 11, 2011
0
(0)

So I have stumbled upon this post and am glad I'm not the only Airport Extreme Basestation user beating their head against the wall with their new Uverse service.  I am currently using my AEBS in bridged mode but I keep getting random errors with pages not loading, google search result links not functioning, pages loading incorrectly etc...  

 

I have read the post entirely and being somewhat of a newby to IP manual configs have no idea what is going on but I think I can struggle through the solution.  

 

So are you all wanting a bridged mode because you're suffering from the same issues as me?  Or are you just wanting to use your AEBS with time capsule updates, wireless printing etc.??

 

I really appreciate anyone who can maybe hold my hand through this process. :-)

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Nov 16, 2011
0
(0)

If you're having random errors with pages not loading, links not functioning, etc, that's probably something else kamickm. If you don't know of a reason to bridge your U-verse modem/router, then you probably don't have a need for it.

 

I bridge my NVG510 because I have my home network highly customized. I use "fixed" IP addresses on some of my devices, for example, and the NVG510 doesn't provide me that capability. So, I need my AEBS to "be the boss of" my home network, rather than letting the NVG510 do it.  Some people have certain ports (openings into and out of the home network) set up in special ways for gaming, say, or other activities they do on their network. The NVG510 doesn't allow you to do these special setups, while the AEBS does.

 

A router is designed to be a traffic director, to put it very simply, on a connection between two networks. By default, it decides where and how network information ("traffic") is sent from one place to another. "Bridge Mode" basically allows a router to just let that network traffic pass through itself so another router can run things. In your case, the AEBS is in Bridge Mode, allowing the NVG510 (or whichever U-verse "Residential Gateway" you have) to make all the decisions about where to send the traffic.

 

The random errors you are getting likely have nothing to do with your AEBS being in Bridge Mode. First thing I would suggest is to connect your computer directly to the U-verse device, without the AEBS between them, and see what happens. If you get the same errors, then while you're set up like that, call AT&T's support hotline. They'll check your line and help you troubleshoot and resolve what's happening. (But, remember, they will NOT help you with anything related to the AEBS - they only support their own equipment. Imagine if you had to support every router in existence - not a happy thing.)

Re: NVG510 Bridge Mode???

[ Edited ]
0
(0)
  • Rate this reply
Nov 16, 2011
0
(0)

kamickrn, I believe I am having the same problem as you.

 

I started a thread for it here: http://forums.att.com/t5/Features-and-How-To/DNS-on-the-NVG510/td-p/2963123

 

I spent about two hours on the phone with support last night and another hour about a week ago. They have no idea and keep telling me nobody else has ever had this problem. Would love to find another example. DNS settings on the local machine can relieve the problem for me, but if I can't fix it for the whole network, I'm going to cancel and return before my 30 days are up. Is this the same problem you're having?

 

Thanks,

-Colin

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Nov 17, 2011
0
(0)

If you are using Safari as your browser, I had the same issue and solved it with two separate steps. 1st, go into terminal and type 

 

defaults write com.apple.safari WebKitDNSPrefetchingEnabled -boolean false

 

that usually does the trick, but you can change up the DNS (as mentioned in the other thread) numbers on each machine to give Safari some extra help. 

 

Repair permission, restart and see if the problem resolves. I haven't had an issue since I stopped the DNS pre-fetching..had nothing to do with the airport or modem. 

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Nov 20, 2011
0
(0)

I just got this working following your instructions.  I just got U-verse with the NVG510 gateway and was having a nighmare of a time getting my AEBS to route packets to my internally port-forwarded devices (I run several network services I expose via dynamic DNS).  The NVG510 kept blocking all the data until I applied your recommendations.

 

Thanks again! :smileyhappy:

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Dec 1, 2011
0
(0)

(see post I replied to below)

 

So what about this dynamic IP (the public internet IP) changing?  You say that it will not UNLESS there is an upgrade or something - which means it very well COULD change.

 

The reason this is concerning for me is because I will put a web server connected to my "home network" and another service will be http posting data to the database on that webserver.  I will use DDNS service like DynamicDNS or TurnKey to make sure my web domain address is always accurately pointing to the public IP address assigned by ATT - however - if that Public IP (Broadband) address changes - then my home router will not be able to receive the internet traffic anymore.  (According to the setup given here - which works great on my Linksys E2000 by the way...thanks!)

 

So how can I avoid any problems with this 'jerry rigged' bridge mode setup when the IP address (public/broadband) from ATT DOES change????  I would hate to lose ANY data that should be posting because it is live data that must be acted upon immediately upon being posted to my web server.

 

OH - and I want to avoid paying for a static IP address - the whole reason for using a DDNS service.

 

Thanks.

----------------------------------------------------------------------------------------------

A long post, but hopefully worth the reading:

 

I had some weird things happening the weekend after I set up my NVG510 as described above in the post starting:

"Okay, so here's what I've done that seems to be working at the moment...

 

- In the NVG510's setup, under Home Network, then Subnets & DHCP, I set the following:"

 

The Issue:

When family members were trying to access the Internet with multiple devices, things kept locking up. Say for example, the kids were trying to watch videos, one on an iPad, the other on an iPod Touch. The videos were buffering really slowly and kept locking up. So... back to the drawing board. Now, I have some interesting findings and a new setup.

 

The Research:

I researched IP-DSL and IP Passthrough a bit. It seems that IP-DSL, which U-verse is using, is actually using IP like a typical ethernet network. (Their prior DSL used ATM, which is a bit more complex technology.) The U-verse Residential Gateway (RG) is getting an IP address and gateway just like anything else you set up with IP and DHCP. The "Broadband IPv4 Address" on the Broadband Status tab is the public IP handed out to the RG. The "Gateway IPv4 Address" is the AT&T router managing the RG (typically called the "Default Gateway").

 

IP Passthrough is supposed to allow another device to receive the IP address of the RG. When IP Passthrough is turned on, then, the NVG510 is supposed to give its own public IP address to a specified LAN device. The instructions on the right-hand side of the IP Passthrough tab confirm this.

 

The Theoretical Setup

To set up the NVG510 correctly, then, for use with a home router (assuming you don't want to simply let your home router be a bridge, of course) -

 

Starting with the NVG510's default settings:

 

- Under Home Network, then Subnets & DHCP, I set the following:

Device IPv4 Address: <the IP address I want to use for the RG (the default is 192.168.1.254, which is okay too)>

DHCPv4 Start Address: <some IP address within the RG's subnet (say 192.168.1.1)>

DHCPv4 End Address:  <the same IP address as the Start Address, above (since I'm not using the NVG510's DHCP)>

 

- Under Home Network, Wireless,

Wireless Operation: Off

 

- Under Firewall, IP Passthrough,

Allocation Mode: Passthrough

Passthrough Mode: DHCPS-fixed

Passthrough Fixed MAC Address: <MAC address of the home router>

 

On the AEBS, then:

 

- Under Internet, Internet Connection,

Connect Using: Ethernet

Connection Sharing: Share a Public IP Address

 

- Under Internet, TCP/IP,

Configure IPv4: DHCP

 

- Under Internet, DHCP, the DHCP values are set as normal, with an address range in a different subnet from the RG, though, in order to prevent double NAT messages. (For example, if the RG is 192.168.1.x, the AEBS is 192.168.2.x)

 

Restart the NVG510, then the AEBS.

 

Theoretically, the NVG510 should, using its own DHCP, give the AEBS its own public IP address (the "Broadband IPv4 Address"), a valid Subnet Mask, and the Default Gateway (Router) value equal to the "Gateway IPv4 Address".

 

In actuality, for some reason, the NVG510 only will give the AEBS its Gateway  and DNS values. The AEBS gets an internal IP address and a Subnet Mask of 255.255.255.255. I suspect a bug, er, "feature", in the NVG510's firmware...

 

The Actual Setup

The fix, then, is to set everything up as described above - except... in the AEBS, I changed the last step:

 

- Under Internet, TCP/IP,

Configure IPv4: Manually

IP Address: <the RG's "Broadband IPv4 Address">

Subnet Mask: 255.255.0.0 (Note that I'm not certain this is correct. The NVG510 doesn't show a subnet mask on its Broadband/Status tab, but the values I have showing would work with this mask.)

Router: <the RG's "Gateway IPv4 Address">

DNS: <the RG's "local" IP address (e.g., 192.168.1.254 by default)>

 

Yay, It Works

No more lockups; everything is running smoothly with multiple devices accessing the Internet at the same time.

 

I'm going to mark this post as the answer, though hopefully I won't later get my hand slapped and told how I terribly messed things up - i.e., anybody trying anything I suggest in any post anywhere does so at their own risk, of course. I don't claim to be an expert - just yet another experimenter in the 'net world. Anybody with more expertise and good explanations is welcome to jump in!

Re: NVG510 Bridge Mode???

[ Edited ]
0
(0)
  • Rate this reply
Dec 1, 2011
0
(0)

I just got this working following your instructions.  I just got U-verse with the NVG510 gateway and was having a nighmare of a time getting my AEBS to route packets to my internally port-forwarded devices (I run several network services I expose via dynamic DNS).  The NVG510 kept blocking all the data until I applied your recommendations.

 

I see your post is very directly related to the question I just asked.  Can you tell me your concerns with using this setup and also using Dynamic DNS services?

 

When the Broadband (public) IP address changes - this set up has your router HARD CODED to use the Broadband IP at the time you set it up.  But when the Broadband IP changes - then your connection will break until you go back into your home router and change to the new Broadband IP.

 

Then all the DDNS services will be for naught as they may be properly updated with the new IP (depending on how you're getting the communication of the new IP to these services) - but any in/out data from your home network will stop at the home router since the home router is now using an incorrect Internet IP address (wrong Broadband IP address)?

 

Please advise of any workarounds.

 

Thank you!

Re: NVG510 Bridge Mode???

[ Edited ]
0
(0)
  • Rate this reply
Dec 2, 2011
0
(0)
I going to be addressing this issue once I get my NVG510 connected computer to be accessible from the public internet. So far, passthrough-NoDHCP-Staticly assigning Divice Address to my computer alows my computer to access the internet, but not the other way around.
I *think* the problem *you* guys are having is that the AEBS is not running the DynamicDNS software. If I am remembering correctly, I expect to have a PC running the DynamicDNS software and it would be connected to the NVG510 via a Networkcard/TCPIP configured Dynamic DNS (not static) and a second Networkcard/TCPIP configured something like 192.168.0.1. This PC would serve as the router for the network.

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Dec 2, 2011
0
(0)
Just revisited the NVG510 configuration and tried to duplicated teh above configuration.
No luck ping and RemoteDesktop still don't find the machine connected to it.

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Dec 5, 2011
0
(0)

drosengarden (and anyone else with concerns about the public IP address changing) - there is currently no workaround of which I am aware to have your router dynamically change with the NVG510.  Read on...

 

According to the instructions on the IP Passthrough page of the NVG510, and as I noted in my "theoretical setup" section, if you set a device's MAC address (presumably the non-NVG510 router) under the IP Passthrough page's DHCPS-Fixed section, the NVG510 is SUPPOSED to pass the public IP address, via DHCP, to the specified device. BUT, it doesn't. Thus, I believe there is a bug, er, "feature", in the NVG510's firmware preventing the DHCPS-Fixed function from working properly.

 

Until such time as that firmware issue is fixed, as long as you're using the solution of "hard coding" the NVG510's address into your router, your connection will be broken if that IP address changes.

 

A self-proclaimed AT&T employee posted earlier in this thread that the IP address should not change under normal circumstances. While I believe that poster (mine hasn't changed in the few months I've had the NVG510 so far), I would advise keeping a constant eye out for the connection's status if you have a critical application running via your U-verse connection.

 

Sorry, but we're talking about a DSL modem that DOESN'T even actually BRIDGE here, so until that's changed or someone finds a better way (I'm totally open to suggestions!), I would just be aware that this is an imperfect, but generally workable, solution.

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Dec 5, 2011
0
(0)

Hello I want to apply this using a d-link dir 827  After applying the settings to the NVG510 what port do I connect it to on the d-link, 1 of the 4 Lan prts or the Internet port that is normally used when connecting to a modem?

 

Thanks

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Dec 7, 2011
0
(0)

This solution used the Internet (WAN) port of the secondary router (AEBS, here, but D-Link for you, bwatching.

Re: NVG510 Bridge Mode???

0
(0)
  • Rate this reply
Dec 9, 2011
0
(0)

Hi there,

 

I did this set up using the actual setup steps.  It worked for me for about three weeks and now out of a sudden it stopped working.  I believe I have tried everything.  I even restored the NVG510 and the Airport extreme to factory settings and set everything up again using the steps outlined.  

 

Any thoughts, why it isn't working now.

 

Please help.

frustrated Uverse customer

Re: NVG510 Bridge Mode???

Share this post
Share this post