Reply
Posted Nov 26, 2012
8:03:04 PM
Forwarding port 443 for WHS - conflict with connectToCiscoAP

I previously had my WHS set up and working fine for remote web acces for use with my AT&T Uverse internet. However, I think the RG has recently had a software update or something, as it has lost all my settings. Now, when I try and set it up to open ports 433, 4125 and 80 for WHS, it comes up with the following error:

 

WHS Ports conflicts with connectToCiscoAP which is currently in use on Cisco_AP_ATT.

WHS Ports and connectToCiscoAP use the same resources and cannot both be hosted at the same time. To use WHS Ports, you must first remove connectToCiscoAP from the application list of Cisco_AP_ATT. Alternatively, you can install the applications on one computer and add both application profiles to the application list for that computer.

 

Any idea whether its safe to remove the "connectToCiscoAP" rule and allow my rule so that I can connet to my WHS from the web? Will it mess up my TV or wireless TV receiver or something? I don't recall having this issue last time I set it up, but may have forgotten!! Many thanks.

0
(0)
  • Rate this reply
Solved
Dec 2, 2012 5:47:36 PM
0
(0)
Expert
No, the switch should not interfere with anything. The switch doesn't know about IP addresses or ports, it operates at a lower layer.

If on the LAN, port 4433 didn't work, then the WHS wasn't configured correctly to switch the connection from 443 to 4433.

Now you say you've switch the WHS port to 433. (You typed 433, when the original port was 443. I don't know if you made a typo, or if you actually changed it to 433 instead of 443). Please verify what port you switched the WHS to.

OK, now remember that all of these ports are used for different things. I was looking up some WHS tech documents, and I can only find that WHS needs 3 ports open for remote access. 80, 443, and 4125.

80 is used for the main web page interface to the server.
443 is used for the secure version of that main web page interface to the server.
4125 is used for RDP (Remote Desktop Protocol).

So here's what I recommend:

1. Using the web link I posted previously:

http://forum.wegotserved.com/index.php/tutorials/article/29-set-up-alternate-ports-for-windows-home-server/

Follow their steps to make sure that your WHS ports are set to 80, 4433, and 4125 for those 3 functions.

2. Verify that they all work from another computer on your LAN:

http://<LAN IP Address of WHS>
https://<LAN IP Address of WHS>:4433
RDP to <LAN IP Address of WHS>:4125

3. Configure the 2Wire gateway like we discussed earlier (remove all your previous entries first). Open only ports 80, 4433, and 4125.

4. Find out your outside IP address by looking at the 2Wire page:

http://192.168.161.254/xslt?PAGE=C_1_0

It will have your external IP address listed under "IP Address".

5. From some other computer on the Internet (friend's house, work computer, etc.) try to access your WHS:

http://<External IP Address>
https://<External IP Address>:4433
RDP to <External IP Address>:4125


There is another article that may be of interest. I found this on Microsoft Technet. This has step-by-step instructions for configuring routers to support external access to WHS. (Although the 2Wire is not listed). Also, this is for an older version of WHS that used port 3389 for RDP vice 4125. However, the article has a lot of information that can be used to verify your setup:

https://social.technet.microsoft.com/wiki/contents/articles/922.windows-home-server-router-setup.aspx

Accepted Solution

Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,805 views
36 replies
(0) Me too
(0) Me too
Post reply
Replies
(36)
0
(0)
  • Rate this reply
Solved
Nov 26, 2012 9:08:24 PM
0
(0)
Expert
The "connectToCiscoAP" rule is automatically added to the RG by AT&T for those people who have wireless STBs. This entry reserves port 443 for the Cisco access point for the wireless STBs so that AT&T can communicate with it and manage it.

If you have wireless STBs and need to use inbound port 443, the only way to get around this entry is to use static IPs ($15/month).

If you remove the connectToCiscoAP entry and put in your own rule for port 443, the AT&T system will remove your entry and replace the connectToCiscoAP entry within a few hours automatically.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

6,174 views
Solution
0
(0)
  • Rate this reply
Nov 27, 2012 4:05:40 AM
0
(0)
ACE - Master

SomeJoe7777 wrote:
The "connectToCiscoAP" rule is automatically added to the RG by AT&T for those people who have wireless STBs. This entry reserves port 443 for the Cisco access point for the wireless STBs so that AT&T can communicate with it and manage it.

If you have wireless STBs and need to use inbound port 443, the only way to get around this entry is to use static IPs ($15/month).

If you remove the connectToCiscoAP entry and put in your own rule for port 443, the AT&T system will remove your entry and replace the connectToCiscoAP entry within a few hours automatically.


So, does that mean everyone with a wireless STB is precluded from running secure web servers/services on the standard ports?

 

You'd think they would use port triggering instead of a continuous forward if it's only for sporadic management access.

 

 

 

 

                               neon_sign.jpg

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

6,139 views
0
(0)
  • Rate this reply
Nov 27, 2012 8:02:33 AM
0
(0)
ACE - Master

Computer-Joe wrote:

So, does that mean everyone with a wireless STB is precluded from running secure web servers/services on the standard ports?

You'd think they would use port triggering instead of a continuous forward if it's only for sporadic management access.


Yes, it means that.

 

Yes, it sounds pretty heavy handed of them.  However, most residences don't run web servers at all, let alone SSL protected ones, and if you're really serious about running a web server at home, you'll probably buy a static IP address.

 

Is it any more heavy handed than preventing you from using 10.0.0.0/8 as your LAN subnet?  Maybe.

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

6,120 views
0
(0)
  • Rate this reply
Nov 27, 2012 4:26:54 PM
0
(0)
Teacher
Thanks For the info SomeJoe7777.

So, not sure if you can help, but is there any way to change the port that my WHS uses for the connection to the internet??!!

Any other ideas on how to get round this, as I'm flatly not paying an extra $15 a month?!!

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

6,097 views
0
(0)
  • Rate this reply
Nov 27, 2012 4:42:37 PM
0
(0)
Expert
Yes, you can assign alternate port numbers to WHS. See the following article:

http://forum.wegotserved.com/index.php/tutorials/article/29-set-up-alternate-ports-for-windows-home-...

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

6,092 views
0
(0)
  • Rate this reply
Nov 28, 2012 4:29:36 PM
0
(0)
Teacher
Thanks for the link. I think I managed to change the WHS ports (I'm using WHS 2011 so it wasn't exactly the same), but I still cant get access to my server from the web; I just get the error:

Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.

I've opened the following TCP ports: 4433, 80, 4125, 65515, 65510, and set the https on the WHS to run on port 4433.

What am i doing wrong??!! I have had it going on AT&T before, but I never went through such issues!!!!

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

6,042 views
0
(0)
  • Rate this reply
Solved
Nov 28, 2012 5:48:32 PM
0
(0)
Expert
You might want to verify that your firewall is properly configured and the proper ports are allowed for inbound traffic. You can do this by going to http://www.canyouseeme.org/ and using their port checking tool. Be aware that this website can only test TCP ports, not UDP.

If the ports are open, then you've configured everything correctly. If not, check the WHS by browsing to it using a computer on your local LAN. If that works, then the WHS is configured correctly and the 2Wire is not. If it doesn't, then the WHS isn't configured correctly to work with the alternate ports.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

6,032 views
Solution
0
(0)
  • Rate this reply
Nov 28, 2012 6:09:22 PM
0
(0)
Teacher
Thats a great site - thanks for the link. So, it turns out I can't access all the ports that I've opened; the only one open was 80 - all the others were closed!

Is there any way to find out a list of ports that AT&T will allow me to open, or is it just a bit of trial and error?!

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

6,030 views
0
(0)
  • Rate this reply
Nov 28, 2012 7:58:59 PM
0
(0)
Expert
You should be able to open any port on the 2Wire except:

443 (because of the wireless STBs)
22 (conflicting reports on whether this can be opened or not)
8000-8015 (reserved for U-Voice VOIP)

For an example of how to open multiple ports for a single application, see the following post:

http://forums.att.com/t5/Residential-Gateway/Security-Camera-Pinholes/m-p/3209955#M5535

Follow the directions under the "2Wire Camera 1 Setup" section, except substitute your own port numbers for the WHS.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

6,006 views
0
(0)
  • Rate this reply
Dec 1, 2012 6:10:34 PM
0
(0)
Teacher
Edited by cocksy on Dec 1, 2012 at 6:17:33 PM

Well, I've folowed those instructions 3 or 4 times creating new rules, but they dont work!

 

The only one I ca get to open up is port 80 - I can turn it off again, so I know I'm doing the process right, but none fo these get opened 4433, 4125, 65515, 65510, according to canyouseeme.org.

 

AT&T Firewall Router Pic.png

 

Any ideas?!

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

[ Edited ]
5,896 views
0
(0)
  • Rate this reply
Dec 1, 2012 11:35:33 PM
0
(0)
Expert
Well, from what I can see on the firewall status screenshot you posted, it looks like you're opening the ports correctly. As far as why the WHS isn't responding, I can't explain. I don't know too much about WHS, so other than pointing you to the article I found on changing it's ports, that's about all I know.

I hate to refer you elsewhere, but you might try a WHS forum and see if they have anything additional to offer. Because at this point, it doesn't look like the firewall is the problem.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,878 views
0
(0)
  • Rate this reply
Dec 2, 2012 8:29:00 AM
0
(0)
Teacher

I know why WHS doesn't respond: because according to the canyouseeme.org site - the ports aren't open, even though the RG syas they are!!

 

Any ideas?!!

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,855 views
0
(0)
  • Rate this reply
Dec 2, 2012 11:43:02 AM
0
(0)
Expert
Edited by SomeJoe7777 on Dec 2, 2012 at 11:43:34 AM

All that the canyouseeme.org site can test is if the TCP connection will open or not. That tells you if it's working, but if it's not, it doesn't tell you why.

If the connection can't be made, that could be because the port isn't open. It could also be because the WHS server isn't responding, even though the ports ARE open. This is what appears to be the case, because your screenshot above clearly shows that the ports are open.

Can you get to the WHS on the LAN? What happens if you go to https://<ip address of WHS>:4433 ?

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

[ Edited ]
5,841 views
0
(0)
  • Rate this reply
Dec 2, 2012 1:09:37 PM
0
(0)
Teacher

Ah, I see, I understand a bit more clearly now!

 

OK, when I go go the address of the WHS on the network & :4433 the page doesn't open, if i go to the IP without 4433 it seems to work. So, it does appear to be something with the WHS, not the Router.

 

I'll do some digging, but I dont know exactly where I should be looking...!! 

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,827 views
0
(0)
  • Rate this reply
Dec 2, 2012 4:07:32 PM
0
(0)
Teacher

Hmmmmm. Help!!!

 

OK, so I played around with the settings on the WHS for a bit, and I think I got them back to the original 433 ports, etc, and when (from RDP into the server) I go to localhost:433, or he IP address and :433 it all works OK. But if I go to the IP address from any other PC on my network, it doesn't work.

 

Then I got thinking; I've recently installed a new switch in my network, a Tenda G1008D. I thought I had remotely access the WHS from the internet since I instaled that, but now I'm not too sure. Everything else on the netowkr is working just fine.

 

Could this be the cause of all the issues? If so, how do I go about resolving it??!! I seems to be working in every othe respect, and as its an unmanaged switch, I don't even know if theres a configuration page I can go to adjust settings?!!

 

Or do I need to open the ports from the RG to the MAC address of the switch? I'm getting a bit out of my depth now....!!! 

 

Any help still appreiated!

 

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,814 views
0
(0)
  • Rate this reply
Solved
Dec 2, 2012 5:47:36 PM
0
(0)
Expert
No, the switch should not interfere with anything. The switch doesn't know about IP addresses or ports, it operates at a lower layer.

If on the LAN, port 4433 didn't work, then the WHS wasn't configured correctly to switch the connection from 443 to 4433.

Now you say you've switch the WHS port to 433. (You typed 433, when the original port was 443. I don't know if you made a typo, or if you actually changed it to 433 instead of 443). Please verify what port you switched the WHS to.

OK, now remember that all of these ports are used for different things. I was looking up some WHS tech documents, and I can only find that WHS needs 3 ports open for remote access. 80, 443, and 4125.

80 is used for the main web page interface to the server.
443 is used for the secure version of that main web page interface to the server.
4125 is used for RDP (Remote Desktop Protocol).

So here's what I recommend:

1. Using the web link I posted previously:

http://forum.wegotserved.com/index.php/tutorials/article/29-set-up-alternate-ports-for-windows-home-...

Follow their steps to make sure that your WHS ports are set to 80, 4433, and 4125 for those 3 functions.

2. Verify that they all work from another computer on your LAN:

http://<LAN IP Address of WHS>
https://<LAN IP Address of WHS>:4433
RDP to <LAN IP Address of WHS>:4125

3. Configure the 2Wire gateway like we discussed earlier (remove all your previous entries first). Open only ports 80, 4433, and 4125.

4. Find out your outside IP address by looking at the 2Wire page:

http://192.168.161.254/xslt?PAGE=C_1_0

It will have your external IP address listed under "IP Address".

5. From some other computer on the Internet (friend's house, work computer, etc.) try to access your WHS:

http://<External IP Address>
https://<External IP Address>:4433
RDP to <External IP Address>:4125


There is another article that may be of interest. I found this on Microsoft Technet. This has step-by-step instructions for configuring routers to support external access to WHS. (Although the 2Wire is not listed). Also, this is for an older version of WHS that used port 3389 for RDP vice 4125. However, the article has a lot of information that can be used to verify your setup:

https://social.technet.microsoft.com/wiki/contents/articles/922.windows-home-server-router-setup.asp...

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,805 views
Solution
0
(0)
  • Rate this reply
Dec 2, 2012 7:55:04 PM
0
(0)
Teacher
Thanks SomeJoe7777 - I'll work through all that step by step tomorrow to make sure everything is tip top!

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,793 views
0
(0)
  • Rate this reply
Dec 3, 2012 7:15:47 AM
0
(0)
ACE - Master

Not sure if this will help, but from what I've read the reason your server is not responding to requests on the newly assigned ports is the server kernal might be hard coded for access ports and if setting alternate ports the server just ignores them or it just breaks access. I believe that to get around this issue (other than to ditch the wireless STB) is either a static IP package so your server has it's own public IP, or a gateway that allows port triggering or does port translation (not 2WIRE). Putting the the server in the DMZ will not work because firewall rules overide DMZ so if port 443 is assigned in a firewall rule, it is unavailable to a DMZed computer.

 

 

 

 




__________________________________________________________
How can you be in two places at once, when your not anywhere at all?
------------------------------------------------------------------------------------------------------
I really want to become a procrastinator, but I keep putting it off.
------------------------------------------------------------------------------------------------------
There are three kinds of people, those that can count, and those that can't.
------------------------------------------------------------------------------------
“Our great democracies still tend to think that a stupid man is more likely to be honest than a clever man, and our politicians take advantage of this prejudice by pretending to be even more stupid than nature has made them." :Bertrand Russell

                               neon_sign.jpg

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,763 views
0
(0)
  • Rate this reply
Dec 3, 2012 8:07:32 PM
0
(0)
Teacher

OK,

 

So I did some work, and it looks like the problem is the settings in WHS. One thing that I failed to highlight is that I'm using WHS 2011, rather than the orignal so the port changing instructions dont quite work, but I thought I had done it correctly.

 

I returned WHS 2011 IIS settings to the standard 433, and removed the CiscoAP port forward 433, it all worked perfectly well.

 

I went through the whole set-up again to change it to port 4433, and ended up with the same error.

So I did it one more time, and this time I remoted in to the WHS from my PC an went to the remote web access area in server settings, and it all came up as 'OK' (as it did previously). Then I went back to the web and it all works OK!!!

 

No ide what i did differently, but it all seems to be working great now. Thanks for all your help! :smileylol:

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,736 views
0
(0)
  • Rate this reply
Dec 3, 2012 8:11:58 PM
0
(0)
Teacher
Crap. I spoke to soon.

I went to put the Cisco back on for port 433, and it causes my server internet web page to timeout immediately, even though my server and the firewall are set to use 4433 and the ciso is 443.

What on earth???!!!

If I were to leave the cisco 443 off, what would be the effect on my Uverse TV?

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,744 views
0
(0)
  • Rate this reply
Dec 3, 2012 8:25:03 PM
0
(0)
Teacher
now I can't get it working again. AAAAArrrgghhhhhh!!!!

This is so annoying as it used to work just fine, and then i think the home gateway had a firmware update (my password reset), and now I am totally stuck!!!

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,740 views
0
(0)
  • Rate this reply
Dec 3, 2012 9:21:47 PM
0
(0)
Expert
Since you're having trouble with getting the WHS to change the port from the default (443), and the Cisco WAP will always override and use 443, there may not be a solution for you unless you purchase static IPs.

If you purchase static IPs, then you can assign one of the statics to the WHS, and the Cisco WAP won't interfere with it.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,737 views
0
(0)
  • Rate this reply
Dec 4, 2012 7:31:33 PM
0
(0)
Teacher
Hmmm. If I turn off the CiscoAP port forwarding on 433, what will be the impact on the WAP / Uverse, and how often will it come back into force?

I'm thinking it might just be easier to live with the fact that sometimes it will automatically come back on, as long as the down sides to it being off aren't too bad.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,698 views
0
(0)
  • Rate this reply
Dec 5, 2012 4:17:22 AM
0
(0)
ACE - Master
Edited by Computer-Joe on Dec 5, 2012 at 4:23:55 AM

cocksy wrote:
Hmmm. If I turn off the CiscoAP port forwarding on 433, what will be the impact on the WAP / Uverse, and how often will it come back into force?

I'm thinking it might just be easier to live with the fact that sometimes it will automatically come back on, as long as the down sides to it being off aren't too bad.


The rule is probably embedded in the firmware, which means that it will probably come back anytime the modem/gateway is rebooted/reset.

 

As Somejoe mentioned, the rule is probably there so AT&T has remote access to the WAP for mods or firmware upgrades and should not impact the day to day operations of it, but if they try to push an update for the WAP, it will fail, and they will probably push a reset for the modem/gateway to ensure the rule is in place. The problem there, is what happens when they decide to do that while you're on the road somewhere and you need acces to your WHS. The only solution there would be to remote in to one of your other computers and then access the modem/gateway from the inside to change the rule back to your WHS, as there is no remote user access for the 2WIREs (other than for AT&T).

 

Yes, it's an ugly solution to a problem that should not exist, but until AT&T decides to add functionality to the 2WIRE's that any other $40 router has (port triggering or port translation), there's not much else to do besides go with a static IP package, or buy another router to place between the 2WIRE and your other devices (one that does port translation).

 

 

 




__________________________________________________________
How can you be in two places at once, when your not anywhere at all?
------------------------------------------------------------------------------------------------------
I really want to become a procrastinator, but I keep putting it off.
------------------------------------------------------------------------------------------------------
There are three kinds of people, those that can count, and those that can't.
------------------------------------------------------------------------------------
“Our great democracies still tend to think that a stupid man is more likely to be honest than a clever man, and our politicians take advantage of this prejudice by pretending to be even more stupid than nature has made them." :Bertrand Russell

                               neon_sign.jpg

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

[ Edited ]
5,667 views
0
(0)
  • Rate this reply
Dec 5, 2012 7:51:07 AM
0
(0)
Expert

Again, as I posted before, the port for the WAP and your WHS is 443, not 433.  You keep typing 433, and I don't know if that is just a typo, or if you're actually trying to use that port for the WHS instead.

 

You cannot just delete the WAP rule.  The AT&T control system will put the rule back within a few hours, making it useless.

 

Again, as I posted before, you have 2 choices:

 

1. Get the WHS working on other ports.  I can't help you with that, I don't have one and I'm not familiar with it.

 

2. Get static IPs.

 

You're wasting your time and ours if you continue to pursue other attempts at a solution that we've already informed you will not work.

 

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,648 views
0
(0)
  • Rate this reply
Dec 5, 2012 5:16:53 PM
0
(0)
Teacher

Hi SomeJoe,

 

Sorry yes - that's just my dyslexia coming in with the 443 / 433!

 

Thanks for your help - I'm not trying to annoy you or waste your time - your help is very much appreciated; I'm just trying to investigate other avenues that might work and getting all the information so I can make a balanced decision on how to progress because I refuse to pay $15 extra on top of what I already pay, just for a service / feature that I only need because the normal service they provide isn't 'standard' (e.g.. A router with uPNP!

 

I missed the bit in your previous post that advises the Cisco WAP rule comes back every few hours, apologies for that.

 

I'm trying to work out what I'm doing wrong with my WHS 2011 ports, but I'm not having much luckt, as most port changing guides are for WHS V1, not 2011 and I'm not sure that they read across properly. I'll keep searching on that front.

 

The most frustrating thing is that I had it working when I first got it all set up with Uverse!!! I think I must have just removed the Cisco WAP port, and it all seemed to work no problems for weeks. It was only after it stopped working whilst I was on holiday that I noticed my password had been reset back to the stock, so presumed a firmware update must have reset that, and bought the Cisco WAP port rule back.

 

Computer-Joe, you mentioned replacing the router / RG as a possible way to overcome this - is that fairly easy to do on Uverse? I would have no issues doing that on a 'normal' internet connections, I'm just not sure how it would impact the U-verse TV side of things, and I don't want to screw that up!!

 

Thanks again.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,583 views
0
(0)
  • Rate this reply
Dec 5, 2012 5:55:20 PM
0
(0)
Expert
Unfortunately, UPnP wouldn't help you here, because the WHS doesn't use UPnP to open ports, at least the older WHS version. If your WHS 2011 does, you would still have to change away from port 443 for it to work.

Adding your own router won't help either, because the 2Wire still would override incoming connections on 443.

There should definitely be a way to change the WHS ports. Keep looking, and I'm sure you'll find a proper procedure for WHS 2011.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,577 views
0
(0)
  • Rate this reply
Dec 5, 2012 6:26:16 PM
0
(0)
Teacher

I do think the WHS 2011 uses uPNP to make sure router ports are openf or it, but as you said, it wont help if 443 is still assigned to the WAP.

 

OK, I'll keep searching for the WHS 2011 method for changing the ports. Thanks for all your help.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,568 views
0
(0)
  • Rate this reply
Dec 6, 2012 4:02:38 AM
0
(0)
ACE - Master

cocksy wrote:

I do think the WHS 2011 uses uPNP to make sure router ports are openf or it, but as you said, it wont help if 443 is still assigned to the WAP.

 

OK, I'll keep searching for the WHS 2011 method for changing the ports. Thanks for all your help.



Yes WHS 2011 does have and will use UPnP, I have not seen any info on disabling UPnP in WHS, only about disabling it on your router if it does not work (which I suggest anyway).

 

WHS 2011 and WHS v1 are different, Microsoft did strip a lot of functionality out of WHS 2011, as they are trying to get rid of WHS and push people into a new "light" version of SBS.

 

When I mentioned using another router, I did not mean replace the 2WIRE.  You would have to insert the router between your 2WIRE and your computers. If you get a router that has port translation, pretty much any brandname router, you can have your requests from the internet come in on the alternate port (4433) and the router will "translate" that external port request to the proper port (443) before forwarding the request to the WHS. This should be much simpler than mucking about with what is probably hard coded in the server kernal.

 

 

 

This is what I did to use an "internal" router (when I had Uverse). I set my "internal" router to use DHCP or Dynamic for the WAN address, plugged it's WAN port in to a LAN port on the 2WIRE, reboot the "internal" router, let the 2WIRE assign a local address to the "internal" router and then set that address to the DMZ in the 2WIRE's management interface. When I go to the "internal" router's management interface it shows as having the same WAN, gateway, and DNS addresses that the 2WIRE uses.


I set the "internal" router to assign addresses to "my" side of the network in a different IP range than what the 2WIRE uses (192.168.2.* instead of 192.168.1.*) but using the same subnet mask (255.255.255.0). You do not need to disable the firewall in the 2WIRE as the DMZ will open a pinhole through it to the address you pick (your internal router). If your have wireless on your new router that your satisfied with and want to keep, just make sure to turn off the wireless in the RG (unless you use any remote control apps for your STBs)


As for the STBs they should be run straight out of the RG with CAT5 or RG6 Coax (or the Cisco WAP).

 

Once your new router is set up you can put the forwarding/translating rule inplace, and everything should be good.

If you've used a router behind a DSL modem this process is pretty much the same, except the 2WIRE does not have a true bridge mode, it uses DMZ.

 

 

 




__________________________________________________________
How can you be in two places at once, when your not anywhere at all?
------------------------------------------------------------------------------------------------------
I really want to become a procrastinator, but I keep putting it off.
------------------------------------------------------------------------------------------------------
There are three kinds of people, those that can count, and those that can't.
------------------------------------------------------------------------------------
“Our great democracies still tend to think that a stupid man is more likely to be honest than a clever man, and our politicians take advantage of this prejudice by pretending to be even more stupid than nature has made them." :Bertrand Russell

                               neon_sign.jpg

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Re: Forwarding port 443 for WHS - conflict with connectToCiscoAP

5,520 views
Share this post
Share this post