Reply
Posted Dec 26, 2013
S3, v4.3 - Contacts not syncing with Google

I have seen this elsewhere but not with my particular problem.

 

I have Samsung, stock, updated to 4.3 from AT&T, non-rooted.

 

Everything has worked fine until, probably, a couple of days ago.  I updated two contacts in google from my PC.  I sync'd to my Nexux 7 with 4.4 and it is fine.  In sync the S3 and all elements sync (app data, calendar...) except contacts.  The updates made on google from PC do not come down to the phone and the sync does not complete.

 

I exported all contacts, deleted everything, tried to sync and nothing came down (all other syncs are fine).  I imported my contacts back.  Everything is fine on google through browser and on Nexus 7.


Any ideas?

Thanks

0
(0)
  • Rate this reply
Solved
12-28-2013 12:59:16 PM
0
(0)

Fixed.  This seems to be a somewhat common problem.

 

1.  Export current contacts to SD or safe storage just in case.

2.  Go to Settings -> Accounts -> Google -> Select your account -> Removing the tick from the Contacts Sync if you can but if not, don't worry

3.  Go to Settings -> Apps -> Scroll to "All" tab, Find "Contacts", Click Force stop and Clear Data
4.  Settings -> Apps -> Scroll to "All" tab, Find "Contacts Storage", Click Force stop and Clear Data

5.  Reboot the phone

6.  Go into Contacts and if you are quick you will see things populating.  You can also wait a minute and everything will be there.  I then tried a sync and it worked just fine.  I would keep the exported file for a while, just in case but you will not need it.

 

sf

Accepted Solution

S3, v4.3 - Contacts not syncing with Google

7,489 views
5 replies
(0) Me too
(0) Me too
Post reply
Replies
(5)
0
(0)
  • Rate this reply
Dec 26, 2013
0
(0)

Update:  I also updated a contact on my Nexus 7 running the latest (4.4.2).  I saved that and it sync'd to google.  I do see the change I made from the Nexus when I look at google from my web browser.  I do not see it on my phone.  Again, the sync on the phone does not complete for contacts but I can manually sync everything but the contacts.

Re: S3, v4.3 - Contacts not syncing with Google

0
(0)
  • Rate this reply
Solved
Dec 28, 2013
0
(0)

Fixed.  This seems to be a somewhat common problem.

 

1.  Export current contacts to SD or safe storage just in case.

2.  Go to Settings -> Accounts -> Google -> Select your account -> Removing the tick from the Contacts Sync if you can but if not, don't worry

3.  Go to Settings -> Apps -> Scroll to "All" tab, Find "Contacts", Click Force stop and Clear Data
4.  Settings -> Apps -> Scroll to "All" tab, Find "Contacts Storage", Click Force stop and Clear Data

5.  Reboot the phone

6.  Go into Contacts and if you are quick you will see things populating.  You can also wait a minute and everything will be there.  I then tried a sync and it worked just fine.  I would keep the exported file for a while, just in case but you will not need it.

 

sf

Re: S3, v4.3 - Contacts not syncing with Google

Solution
0
(0)
  • Rate this reply
Dec 28, 2013
0
(0)

This worked for me with the addition of 1 thing: if you turn off Contacts syncing, you have to turn it back on.

Re: S3, v4.3 - Contacts not syncing with Google

0
(0)
  • Rate this reply
Feb 2, 2014
0
(0)

I have two Samsung Galaxy S3 phones.

 

Although this seems to be the most common solution for those having the contact syncing problem, it does not correct my situation.  After upgrading to Android 4.3 the sync of contacts on 1 of my phones gets a sync error.

 

It stops with a message   -   Last synced on 01/23/2014 3:15 PM  (the date of the upgrade) 

After clicking Cancel Sync, it states Sync is currently experiencing problems.  It will be back shortly.

If I click Sync Now again, it will sync the calendar and fail with the above stated message.

 

Is my problem different than the others documented in the various Forums?

Re: S3, v4.3 - Contacts not syncing with Google

0
(0)
  • Rate this reply
Feb 2, 2014
0
(0)

My situation occurred after teh 4.3 upgrade too.  However, the procedure, with the addition of turning syncing back on, solved my problem.  I am currently running 4.3 and it is syncing normally.

 

fyi

Re: S3, v4.3 - Contacts not syncing with Google

Share this post
Share this post